Mon, 14 May 2018 13:11:04 +0200 help: add new deprecated topic
David Demelier <markand@malikania.fr> [Mon, 14 May 2018 13:11:04 +0200] rev 37998
help: add new deprecated topic Add a deprecated topic which lists most of the commands and options that are not recommended anymore.
Mon, 14 May 2018 23:00:30 -0400 phabricator: split auth.url into the standard auth.schemes and auth.prefix
Matt Harbison <matt_harbison@yahoo.com> [Mon, 14 May 2018 23:00:30 -0400] rev 37997
phabricator: split auth.url into the standard auth.schemes and auth.prefix It seems better to reuse the existing function to find the proper [auth] block, even if not all of the possible settings may be of interest. The other callers of readauthforuri() make a trip through the password database to fetch the user from the URI. But in the little experimenting I did here, the username always came back as None. Since readauthforuri() wants it to make sure that user@prefix matches user@url, it seems that parsing the URL and pulling out the user component should be equivalent.
Sat, 12 May 2018 00:34:01 -0400 phabricator: migrate [phabricator.auth] to [auth]
Matt Harbison <matt_harbison@yahoo.com> [Sat, 12 May 2018 00:34:01 -0400] rev 37996
phabricator: migrate [phabricator.auth] to [auth] This resurrects the warning mechanism removed in 20a4543e9a2b. I'm not worried about the copy/paste of the code for a brief transitional period.
Sat, 12 May 2018 15:33:09 +0900 dispatch: unify handling of None returned by a command function
Yuya Nishihara <yuya@tcha.org> [Sat, 12 May 2018 15:33:09 +0900] rev 37995
dispatch: unify handling of None returned by a command function A command function may return None in place of 0 just for convenience, but dispatch() doesn't need to inherit that property. This patch makes it be friendly to callers.
Fri, 11 May 2018 21:23:48 -0700 dispatch: minor code refactor
Gregory Szorc <gregory.szorc@gmail.com> [Fri, 11 May 2018 21:23:48 -0700] rev 37994
dispatch: minor code refactor This hopefully makes things slightly easier to read. Differential Revision: https://phab.mercurial-scm.org/D3537
Wed, 04 Apr 2018 21:17:55 +0900 hgweb: drop unused argument 'tmpl' from webutil.compare()
Yuya Nishihara <yuya@tcha.org> [Wed, 04 Apr 2018 21:17:55 +0900] rev 37993
hgweb: drop unused argument 'tmpl' from webutil.compare()
Wed, 04 Apr 2018 21:17:10 +0900 hgweb: convert {comparison} to a mappinggenerator with named template
Yuya Nishihara <yuya@tcha.org> [Wed, 04 Apr 2018 21:17:10 +0900] rev 37992
hgweb: convert {comparison} to a mappinggenerator with named template No bare generator.
Wed, 04 Apr 2018 21:14:30 +0900 hgweb: rename 'context' argument of webutil.compare() to avoid name conflicts
Yuya Nishihara <yuya@tcha.org> [Wed, 04 Apr 2018 21:14:30 +0900] rev 37991
hgweb: rename 'context' argument of webutil.compare() to avoid name conflicts The meaning of 'context' depends on context. Here it is the number of the context lines in unified diff.
Wed, 04 Apr 2018 00:08:10 +0900 hgweb: convert comparison {lines} to a mappinggenerator with named template
Yuya Nishihara <yuya@tcha.org> [Wed, 04 Apr 2018 00:08:10 +0900] rev 37990
hgweb: convert comparison {lines} to a mappinggenerator with named template Bare generator can't be restarted.
Tue, 03 Apr 2018 23:57:00 +0900 hgweb: move getblock() closure out of compare()
Yuya Nishihara <yuya@tcha.org> [Tue, 03 Apr 2018 23:57:00 +0900] rev 37989
hgweb: move getblock() closure out of compare() (Please use 'hg diff -w' to get readable diff from this patch.)
(0) -30000 -10000 -3000 -1000 -300 -100 -10 +10 +100 +300 +1000 +3000 +10000 tip