Sun, 01 May 2011 13:07:00 +0200 fix bookmarks rollback behavior stable
Alexander Solovyov <alexander@solovyov.net> [Sun, 01 May 2011 13:07:00 +0200] rev 14266
fix bookmarks rollback behavior Before this patch undo.bookmarks was created on bookmarks write and not with other transaction-related files. There were two issues: first is that if you have changed bookmarks few times after a transaction happened, rollback will give you a state which can point to non-existing revision. Second is that if you have not changed bookmarks after a transaction, rollback will touch your state anyway. This change also adds `localrepo._writejournal` method, which can be used by other extensions to save their transaction-related backup in right time.
Sun, 01 May 2011 12:29:32 +0200 add positional arguments to non-shell aliases
Alexander Solovyov <alexander@solovyov.net> [Sun, 01 May 2011 12:29:32 +0200] rev 14265
add positional arguments to non-shell aliases
Sat, 07 May 2011 21:01:15 +0300 run-tests: take the basepath when constructing the test temp dir
Idan Kamara <idankk86@gmail.com> [Sat, 07 May 2011 21:01:15 +0300] rev 14264
run-tests: take the basepath when constructing the test temp dir so it's possible to run tests that are outside the test/ dir
Sat, 07 May 2011 20:56:43 +0300 run-tests: compare absolute paths in _checkhglib
Idan Kamara <idankk86@gmail.com> [Sat, 07 May 2011 20:56:43 +0300] rev 14263
run-tests: compare absolute paths in _checkhglib
Sat, 07 May 2011 22:25:20 +0200 util: rename _windows_reserved_filenames and _windows_reserved_chars
Adrian Buehlmann <adrian@cadifra.com> [Sat, 07 May 2011 22:25:20 +0200] rev 14262
util: rename _windows_reserved_filenames and _windows_reserved_chars
Sat, 07 May 2011 20:22:32 +0200 opener: rename _can_symlink to _cansymlink
Adrian Buehlmann <adrian@cadifra.com> [Sat, 07 May 2011 20:22:32 +0200] rev 14261
opener: rename _can_symlink to _cansymlink
Sun, 08 May 2011 17:48:31 +0200 patch: make patch()/internalpatch() always update the dirstate
Patrick Mezard <pmezard@gmail.com> [Sun, 08 May 2011 17:48:31 +0200] rev 14260
patch: make patch()/internalpatch() always update the dirstate
Sun, 08 May 2011 17:48:30 +0200 patch: move updatedir() from cmdutil into patch
Patrick Mezard <pmezard@gmail.com> [Sun, 08 May 2011 17:48:30 +0200] rev 14259
patch: move updatedir() from cmdutil into patch Also, create an artificial wdutil.py to avoid import cycles between patch.py and cmdutil.py.
Sun, 08 May 2011 17:48:29 +0200 record: unconditionally update the working dir after patching
Patrick Mezard <pmezard@gmail.com> [Sun, 08 May 2011 17:48:29 +0200] rev 14258
record: unconditionally update the working dir after patching
Sun, 08 May 2011 17:48:29 +0200 mq: explicitly updatedir() even if patch() fails
Patrick Mezard <pmezard@gmail.com> [Sun, 08 May 2011 17:48:29 +0200] rev 14257
mq: explicitly updatedir() even if patch() fails It already works that way in practice, and we intend to merge updatedir() into patch().
Fri, 06 May 2011 19:55:46 +0300 mq: allow to qpop/push with a dirty working copy (issue2780)
Idan Kamara <idankk86@gmail.com> [Fri, 06 May 2011 19:55:46 +0300] rev 14256
mq: allow to qpop/push with a dirty working copy (issue2780) It's safe to do so if the sets of changed files in the working copy and patches are disjoint.
Fri, 06 May 2011 19:03:41 +0300 patch: introduce changedfiles
Idan Kamara <idankk86@gmail.com> [Fri, 06 May 2011 19:03:41 +0300] rev 14255
patch: introduce changedfiles returns the set of all changed files in a given patch
Sat, 07 May 2011 23:14:36 +0200 debugindex: change output for generaldelta revlogs
Sune Foldager <cryo@cyanite.org> [Sat, 07 May 2011 23:14:36 +0200] rev 14254
debugindex: change output for generaldelta revlogs For generaldelta revlogs, reporting the deltaparent instead of the chain base makes more sense, since that's what's actually stored in the revlog.
Sat, 07 May 2011 22:40:17 +0200 revlog: support reading generaldelta revlogs
Sune Foldager <cryo@cyanite.org> [Sat, 07 May 2011 22:40:17 +0200] rev 14253
revlog: support reading generaldelta revlogs Generaldelta is a new revlog global flag. When it's turned on, the base field of each revision entry holds the deltaparent instead of the base revision of the current delta chain. This allows for great potential flexibility when generating deltas, as any revision can serve as deltaparent. Previously, the deltaparent for revision r was hardcoded to be r - 1. The base revision of the delta chain can still be accessed as before, since it is now computed in an iterative fashion, following the deltaparents backwards.
Sat, 07 May 2011 22:40:14 +0200 revlog: calculate base revisions iteratively
Sune Foldager <cryo@cyanite.org> [Sat, 07 May 2011 22:40:14 +0200] rev 14252
revlog: calculate base revisions iteratively This is in preparation for generaldelta, where the revlog entry base field is reinterpreted as the deltaparent. For that reason we also rename the base function to chainbase. Without generaldelta, performance is unaffected, but generaldelta will suffer from this in _addrevision, since delta chains will be walked repeatedly. A cache has been added to eliminate this problem completely.
Sat, 07 May 2011 22:37:40 +0200 revlog: remove the last bits of punched/shallow
Sune Foldager <cryo@cyanite.org> [Sat, 07 May 2011 22:37:40 +0200] rev 14251
revlog: remove the last bits of punched/shallow Most of it was removed in e7483ec3c374, but a few pieces were accidentally left behind.
Sat, 07 May 2011 21:12:35 +0200 util: make readfile() operate in binary mode
Patrick Mezard <pmezard@gmail.com> [Sat, 07 May 2011 21:12:35 +0200] rev 14250
util: make readfile() operate in binary mode writefile() and appendfile() are already working that way.
Sat, 07 May 2011 21:12:33 +0200 cmdutil: normalize log message eols when reading from file
Patrick Mezard <pmezard@gmail.com> [Sat, 07 May 2011 21:12:33 +0200] rev 14249
cmdutil: normalize log message eols when reading from file This will be necessary once util.readfile() operates in binary mode. While changelog.add() already normalizes the message, doing so in logmessage() is required as ui.edit() or others expect messages with LF only.
Sat, 07 May 2011 21:12:30 +0200 match: make 'listfile:' split on LF and CRLF
Patrick Mezard <pmezard@gmail.com> [Sat, 07 May 2011 21:12:30 +0200] rev 14248
match: make 'listfile:' split on LF and CRLF We want util.readfile() to operate in binary mode, so EOLs have to be handled correctly depending on the platform. It seems both easier and more convenient to treat LF and CRLF the same way on all platforms.
Sat, 07 May 2011 17:25:12 +0200 progress: remove useless statement left by bab267e7fc1a
Patrick Mezard <pmezard@gmail.com> [Sat, 07 May 2011 17:25:12 +0200] rev 14247
progress: remove useless statement left by bab267e7fc1a
Sat, 07 May 2011 17:25:02 +0200 debugbuilddag: simplify tags serialization a bit
Patrick Mezard <pmezard@gmail.com> [Sat, 07 May 2011 17:25:02 +0200] rev 14246
debugbuilddag: simplify tags serialization a bit
Mon, 02 May 2011 12:10:50 -0500 httprepo: send 100-continue on POSTs if using http2
Augie Fackler <durin42@gmail.com> [Mon, 02 May 2011 12:10:50 -0500] rev 14245
httprepo: send 100-continue on POSTs if using http2
Fri, 06 May 2011 10:22:08 -0500 url: use new http support if requested by the user
Augie Fackler <durin42@gmail.com> [Fri, 06 May 2011 10:22:08 -0500] rev 14244
url: use new http support if requested by the user The new http library is wired in via an extra module (httpconnection.py), as it requires similar but different plumbing to connect the library to Mercurial's internals and urllib2. Eventualy we should be able to remove all of keepalive.py and its associated tangle in url.py and replace it all with the code in httpconnection.py. To use the new library, set 'ui.usehttp2' to true. The underlying http library uses the logging module liberally, so if things break you can use 'ui.http2debuglevel' to set the log level to INFO or DEBUG to get that logging information (for example, ui.http2debuglevel=info.)
Fri, 06 May 2011 09:57:55 -0500 Import new http library as mercurial.httpclient.
Augie Fackler <durin42@gmail.com> [Fri, 06 May 2011 09:57:55 -0500] rev 14243
Import new http library as mercurial.httpclient. This is revision a4229f13c374 of http://py-nonblocking-http.googlecode.com/ with a no-check-code comment added to the end of each file using `for fi in $(hg manifest | grep mercurial/httpclient/) ; echo '# no-check-code' >> $fi`.
Fri, 06 May 2011 15:48:04 -0300 commands, i18n: add translation hint for split message
Wagner Bruna <wbruna@softwareexpress.com.br> [Fri, 06 May 2011 15:48:04 -0300] rev 14242
commands, i18n: add translation hint for split message
Fri, 06 May 2011 19:03:45 +0300 mq: don't hide the patch module
Idan Kamara <idankk86@gmail.com> [Fri, 06 May 2011 19:03:45 +0300] rev 14241
mq: don't hide the patch module
Fri, 06 May 2011 18:45:12 +0300 patch: remove unused ui arg to iterhunks
Idan Kamara <idankk86@gmail.com> [Fri, 06 May 2011 18:45:12 +0300] rev 14240
patch: remove unused ui arg to iterhunks
Fri, 06 May 2011 18:45:12 +0300 mq: loosen except clause when reading patch headers
Idan Kamara <idankk86@gmail.com> [Fri, 06 May 2011 18:45:12 +0300] rev 14239
mq: loosen except clause when reading patch headers
Fri, 06 May 2011 13:04:24 -0500 merge with abuehl
Matt Mackall <mpm@selenic.com> [Fri, 06 May 2011 13:04:24 -0500] rev 14238
merge with abuehl
Fri, 06 May 2011 15:41:04 +0200 rename util.set_signal_handler to setsignalhandler
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 15:41:04 +0200] rev 14237
rename util.set_signal_handler to setsignalhandler
Fri, 06 May 2011 15:36:05 +0200 rename util.executable_path to executablepath
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 15:36:05 +0200] rev 14236
rename util.executable_path to executablepath
Fri, 06 May 2011 15:34:34 +0200 rename util.os_link to oslink
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 15:34:34 +0200] rev 14235
rename util.os_link to oslink
Fri, 06 May 2011 15:31:09 +0200 rename explain_exit to explainexit
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 15:31:09 +0200] rev 14234
rename explain_exit to explainexit
Fri, 06 May 2011 15:25:35 +0200 rename util.set_binary to setbinary
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 15:25:35 +0200] rev 14233
rename util.set_binary to setbinary
Fri, 06 May 2011 15:22:31 +0200 rename util.set_flags to setflags
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 15:22:31 +0200] rev 14232
rename util.set_flags to setflags
Fri, 06 May 2011 15:19:48 +0200 rename util.parse_patch_output to parsepatchoutput
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 15:19:48 +0200] rev 14231
rename util.parse_patch_output to parsepatchoutput
Fri, 06 May 2011 15:16:22 +0200 rename util.lookup_reg to lookupreg
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 15:16:22 +0200] rev 14230
rename util.lookup_reg to lookupreg
Fri, 06 May 2011 15:13:46 +0200 rename util.set_hgexecutable to _sethgexecutable
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 15:13:46 +0200] rev 14229
rename util.set_hgexecutable to _sethgexecutable
Fri, 06 May 2011 15:10:29 +0200 rename util.main_is_frozen to mainfrozen
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 15:10:29 +0200] rev 14228
rename util.main_is_frozen to mainfrozen
Fri, 06 May 2011 15:02:53 +0200 scmutil: rename local function _add_dir_if_not_there
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 15:02:53 +0200] rev 14227
scmutil: rename local function _add_dir_if_not_there
Fri, 06 May 2011 14:58:04 +0200 rename scmutil.user_rcpath to userrcpath
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 14:58:04 +0200] rev 14226
rename scmutil.user_rcpath to userrcpath
Fri, 06 May 2011 14:54:05 +0200 rename scmutil.system_rcpath to systemrcpath
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 14:54:05 +0200] rev 14225
rename scmutil.system_rcpath to systemrcpath
Fri, 06 May 2011 14:52:25 +0200 rename scmutil.os_rcpath to osrcpath
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 14:52:25 +0200] rev 14224
rename scmutil.os_rcpath to osrcpath
Fri, 06 May 2011 11:51:18 -0500 merge with stable
Matt Mackall <mpm@selenic.com> [Fri, 06 May 2011 11:51:18 -0500] rev 14223
merge with stable
Fri, 06 May 2011 11:50:58 -0500 merge with crew
Matt Mackall <mpm@selenic.com> [Fri, 06 May 2011 11:50:58 -0500] rev 14222
merge with crew
Fri, 06 May 2011 14:29:53 +0200 merge with stable
Martin Geisler <mg@aragost.com> [Fri, 06 May 2011 14:29:53 +0200] rev 14221
merge with stable The change from 7b627923739f (parent 2) is not needed after switching to the new url parser.
Fri, 06 May 2011 09:54:06 +0200 rename path_auditor to pathauditor
Adrian Buehlmann <adrian@cadifra.com> [Fri, 06 May 2011 09:54:06 +0200] rev 14220
rename path_auditor to pathauditor The Mercurial 1.9 release is moving a lot of stuff around anyway and we are already moving path_auditor from util.py to scmutil.py for that release. So this seems like a good opportunity to do such a rename. It also strengthens the current project policy to avoid underbars in names.
Fri, 06 May 2011 12:09:20 +0200 revlog: use real Booleans instead of 0/1 in nodesbetween
Martin Geisler <mg@aragost.com> [Fri, 06 May 2011 12:09:20 +0200] rev 14219
revlog: use real Booleans instead of 0/1 in nodesbetween
Fri, 06 May 2011 11:31:40 +0200 patch: fix clash between local variable and exception instance
Martin Geisler <mg@aragost.com> [Fri, 06 May 2011 11:31:40 +0200] rev 14218
patch: fix clash between local variable and exception instance The local err variable would be bound to PatchError thrown and it keeps this value even after the except block is executed. The whole thing worked anyway since the rejected variable is set in the except block and this makes the function return -1 when a PatchError is thrown.
Fri, 06 May 2011 11:12:55 +0200 patchfile: use real Booleans instead of 0/1
Martin Geisler <mg@aragost.com> [Fri, 06 May 2011 11:12:55 +0200] rev 14217
patchfile: use real Booleans instead of 0/1
Fri, 06 May 2011 11:11:55 +0200 annotate: use real Booleans instead of 0/1
Martin Geisler <mg@aragost.com> [Fri, 06 May 2011 11:11:55 +0200] rev 14216
annotate: use real Booleans instead of 0/1
Fri, 06 May 2011 10:02:46 +0200 hbisect: use real Booleans instead of 0/1
Martin Geisler <mg@aragost.com> [Fri, 06 May 2011 10:02:46 +0200] rev 14215
hbisect: use real Booleans instead of 0/1
Fri, 06 May 2011 14:45:13 +0200 summary: run discovery only once for in/out against same repo
Peter Arrenbrecht <peter.arrenbrecht@gmail.com> [Fri, 06 May 2011 14:45:13 +0200] rev 14214
summary: run discovery only once for in/out against same repo Reuses the result of findcommonincoming if default and default-push are the same.
Fri, 06 May 2011 14:44:18 +0200 discovery: resurrect findoutgoing as findcommonoutgoing for extension hooks
Peter Arrenbrecht <peter.arrenbrecht@gmail.com> [Fri, 06 May 2011 14:44:18 +0200] rev 14213
discovery: resurrect findoutgoing as findcommonoutgoing for extension hooks discovery.findoutgoing used to be a useful hook for extensions like hgsubversion. This patch reintroduces this version of findcommonincoming which is meant to be used when computing outgoing changesets.
Fri, 06 May 2011 16:00:48 +0300 transplant: remove unneeded loop over repo in revset
Idan Kamara <idankk86@gmail.com> [Fri, 06 May 2011 16:00:48 +0300] rev 14212
transplant: remove unneeded loop over repo in revset
Fri, 06 May 2011 15:37:38 +0300 transplant: fix revset doc stable
Idan Kamara <idankk86@gmail.com> [Fri, 06 May 2011 15:37:38 +0300] rev 14211
transplant: fix revset doc
Fri, 06 May 2011 16:07:35 +0300 mq: add a 'mq()' revset predicate that returns applied mq csets
Idan Kamara <idankk86@gmail.com> [Fri, 06 May 2011 16:07:35 +0300] rev 14210
mq: add a 'mq()' revset predicate that returns applied mq csets
Fri, 06 May 2011 10:17:07 -0500 pyflakes: ignore files marked no-check-code
Augie Fackler <durin42@gmail.com> [Fri, 06 May 2011 10:17:07 -0500] rev 14209
pyflakes: ignore files marked no-check-code
Thu, 05 May 2011 18:05:24 +0200 revlog: compute correct deltaparent in the deltaparent function
Sune Foldager <cryo@cyanite.org> [Thu, 05 May 2011 18:05:24 +0200] rev 14208
revlog: compute correct deltaparent in the deltaparent function It now returns nullrev for chain base revisions, since they are conceptually deltas against nullrev. The revdiff function was updated accordingly.
Thu, 05 May 2011 11:33:02 -0400 changelog: fixes leaked file handle
Zachary Gramana <zgramana@pottsconsultinggroup.com> [Thu, 05 May 2011 11:33:02 -0400] rev 14207
changelog: fixes leaked file handle
(0) -10000 -3000 -1000 -300 -100 -60 +60 +100 +300 +1000 +3000 +10000 +30000 tip