Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:40 -0600] rev 5740
atomictempfile: avoid chmod weirdness on Linux vfat
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:40 -0600] rev 5739
checkexec: fix VFAT tempfile droppings with more modern Linux kernels
More recent Linux kernels don't pretend to allow any bogus chmods on
VFAT.
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:40 -0600] rev 5738
bisect: use proper locking when updating bisect.state
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:40 -0600] rev 5737
bisect: remove class
- rename core function to _bisect
- rename command function to bisect
- move state management to bisect
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:40 -0600] rev 5736
bisect: keep history of all bad revisions
- use a single state dict
- find the minimum bad revision
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:40 -0600] rev 5735
bisect: use more standard command syntax and help
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:40 -0600] rev 5734
bisect: move reporting out of core bisect function
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:40 -0600] rev 5733
bisect: add skip command
- read/write skip lines in state
- skip candidates in skipnodes
- move bisect begin logic to next
- add skip command
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5732
bisect: simplify state handling and init
- use a single bisect.state file
- unify init and reset (delete the state)
- move write into good/bad
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5731
bisect: remove unused imports
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5730
bisect: rename autobad/good/next
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5729
bisect: slightly improve the help message
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5728
bisect: remove stale test function
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5727
bisect: use array.array rather than lists for ancestor lists
This nearly doubles performance and cuts memory usage in half on large
bisections.
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5726
bisect: switch individual ancestor lists from dict to list
This saves quite a lot of memory and increases performance
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5725
bisect: turn ancestors into an array
This makes things faster and eliminates the separate stop hash
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5724
bisect: greatly simplify the ancestor accumulating loop
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5723
bisect: switch to rev-based calculation
- use revlog.parentrevs in search loops
- calculate stop directly in O(N) without reachable
- move badrev check into candidates
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5722
bisect: fix up node vs rev naming
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5721
bisect: clarify some bisection code
- rename __ancestors... to candidates
- remove head parameter (it's always badrev)
- eliminate comprehensions to shrink parents
- num_ancestors -> n_child name fix
- clarify node selection
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5720
bisect: inline num_children function
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5719
bisect: remove usage of sets
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5718
bisect: remove stop argument to ancestors function
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5717
bisect: use bail_if_changed
- switch to using existing bail_if_changed code
- only abort when we're about to do an update
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5716
cmdutil: make bail_if_changed bail on uncommitted merge
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5715
bisect: remove versionstr
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5714
bisect: simplify lookup
- use repo.lookup directly
- move merge check to check_clean
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5713
bisect: remove redundant clean checks
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5712
bisect: fold in two trivial functions
Matt Mackall <mpm@selenic.com> [Thu, 27 Dec 2007 23:55:39 -0600] rev 5711
bisect: remove two unused functions