Yuya Nishihara <yuya@tcha.org> [Wed, 28 Mar 2018 22:04:45 +0900] rev 37139
alias: reject non-ascii characters in user help/doc strings
Since command doc/help texts are passed to i18n.gettext(), they must be
ASCII. Otherwise, UnicodeError would be raised.
Matt Harbison <matt_harbison@yahoo.com> [Mon, 26 Mar 2018 22:18:36 -0400] rev 37138
lfs: respect narrowmatcher when testing to add 'lfs' requirement (
issue5794)
There's a similar test in lfs.wrapper.convertsink(), but I didn't update that
because I don't think that the sink repo in a convert can be narrow.
It seems reasonable that a narrow clone of an LFS repo may not necessarily be an
LFS repo. The only potential issue is that LFS has a hard requirement for
changegroup v3, which that extension enables. The use of treemanifest will
enable changegroup v3 in narrow clones, because allsupportedversions() in
changegroup.py preserves it when it sees a 'treemanifest' requirement. But I
don't see where changegroup v3 is enabled for a flat manifest.
Gregory Szorc <gregory.szorc@gmail.com> [Tue, 20 Mar 2018 18:02:16 -0700] rev 37137
localrepo: make filterpats private (API)
I'm not sure why this is available on the public API. AFAICT it isn't
used outside of the class.
.. api::
localrepo.localrepository.filterpats was renamed to
localrepo.localrepository._filterpats.
Differential Revision: https://phab.mercurial-scm.org/D2927
Gregory Szorc <gregory.szorc@gmail.com> [Tue, 20 Mar 2018 17:34:05 -0700] rev 37136
narrow: use featuresetupfuncs
This is the preferred way to register repo requirements that can be
opened because it respects the set of loaded extensions at repo open
time.
Differential Revision: https://phab.mercurial-scm.org/D2926
Gregory Szorc <gregory.szorc@gmail.com> [Tue, 20 Mar 2018 17:30:30 -0700] rev 37135
localrepo: move featuresetupfuncs out of localrepository class (API)
I want to establish an interface for local repositories.
featuresetupfuncs is a class attribute and is global/shared across all
localrepository instances. Let's move it to a module-level attribute
to clarify it isn't part of the local repository interface.
.. api::
localrepo.localrepository.featuresetupfuncs has been renamed to
localrepo.featuresetupfuncs.
Differential Revision: https://phab.mercurial-scm.org/D2925
Rodrigo Damazio <rdamazio@google.com> [Sun, 04 Mar 2018 17:11:33 -0500] rev 37134
help: supporting both help and doc for aliases
This allows an alias to be definted like:
[alias]
lj = log -Tjson
lj:help = [-r REV]
lj:doc = Shows the revision log in JSON format.
Differential Revision: https://phab.mercurial-scm.org/D2678
Sangeet Kumar Mishra <mail2sangeetmishra@gmail.com> [Tue, 27 Mar 2018 20:21:30 +0530] rev 37133
grep: fixes erroneous output of grep in forward order (
issue3885)
If grep is passed a revset in forwards order via -r , say -r 0:tip
Then the output is erroneous. This patch fixes that. The output was wrong
because we deleted the last revision key in the matches and when we moved
to the next revision we didn't had this to compare the diff. So the pstates
dict was always empty and in the SequenceMatcher, to convert and empty pstate
to the states dictionary you would always insert. This patch keeps the matches
dictionary until the end of this window and clears it at once when this
window ends. This solves the above mentioned problem and also do not cause
any memory leak.
Matt Harbison <matt_harbison@yahoo.com> [Mon, 26 Mar 2018 23:02:50 -0400] rev 37132
lfs: move the 'supportedoutgoingversions' handling to changegroup.py
This handling already exists here for the narrow extension. We still need to
either figure out how to enable changegroup v3 without the extension, or figure
out how to let the server detect that the client doesn't have it loaded, and
emit a user friendly error[1]. I can't tell if D1944 is the appropriate vehicle
for the latter.
[1] https://www.mercurial-scm.org/pipermail/mercurial-devel/2018-January/109550.html
Gregory Szorc <gregory.szorc@gmail.com> [Sun, 04 Mar 2018 09:58:57 -0500] rev 37131
obsolete: refactor function for getting obsolete options
The function for returning obsolete option values obtains all
options, validates, then returns the option that was requested.
Let's create a new function to return all obsolete option values
so callers needing multiple values can call that.
Differential Revision: https://phab.mercurial-scm.org/D2667
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 26 Mar 2018 14:17:01 -0700] rev 37130
setup: install cbor packages
Without this, standalone installs don't have the cbor files.
Differential Revision: https://phab.mercurial-scm.org/D2949
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 26 Mar 2018 09:21:07 -0700] rev 37129
wireproto: review fixups
Capture various TODOs and return an explicit value. This
represents feedback from Yuya and Augie on various commits.
Differential Revision: https://phab.mercurial-scm.org/D2944
Pulkit Goyal <7895pulkit@gmail.com> [Mon, 26 Mar 2018 10:22:13 -0700] rev 37128
cbor: add a __init__.py to top level cbor module
Differential Revision: https://phab.mercurial-scm.org/D2752
Pulkit Goyal <7895pulkit@gmail.com> [Mon, 26 Mar 2018 08:32:21 -0700] rev 37127
cbor: fix core test-check*
This patch fixes couple of test-check* tests by making sure they skip
testing the third party library cbor.
Differential Revision: https://phab.mercurial-scm.org/D2751
Pulkit Goyal <7895pulkit@gmail.com> [Mon, 26 Mar 2018 08:33:57 -0700] rev 37126
thirdparty: vendor cbor2 python library
CBOR stands for Concise Binary Object Representation, which is a data format
which is very compact and extensible.
This patch moves the python library which can serilaize and deserialize python
objects to/from cbor formats. The library is taken from
https://github.com/agronholm/cbor2/ from commit
84181540f6eb650437e3f73cd104a65661fe8e67.
Unrequired files from the cbor library - docs/, tests/, setup.py, setup.cfg,
and tox.ini - have not been vendored.
There is another python library for cbor at
https://github.com/brianolson/cbor_py/ which is used in evolve extension and was
imported in initial version of this series. That library though contains C code
and is bit faster, but has known bugs around serializing nested structures, is
unmaintained, raises an Exception object instead of a more dedicated Error type.
So, it's better to use a bug free and actively maintained library.
This library is not yet used and will be used in later commits.
# no-check-commit because we are importing a third library module
Differential Revision: https://phab.mercurial-scm.org/D2750
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 00:30:00 -0500] rev 37125
merge: deprecate accessing update results by index
Now that we have named attributes, let's convert the code base to use
them. We also add deprecation warnings so legacy consumers are aware
of their transgressions.
``stats.unresolvedcount`` is much easier to read than ``stats[3]``,
don't you think?
Differential Revision: https://phab.mercurial-scm.org/D2694
Yuya Nishihara <yuya@tcha.org> [Sun, 25 Mar 2018 11:58:05 +0900] rev 37124
procutil: introduce context-manager interface for protect/restorestdio
The code looks slightly cleaner since it was pretty easy to pass arguments
in wrong order.
Yuya Nishihara <yuya@tcha.org> [Sun, 25 Mar 2018 11:40:30 +0900] rev 37123
procutil: move protectio/restoreio from commandserver
Some variants of this will be useful for stdio-based servers such as
sshserver.
Yuya Nishihara <yuya@tcha.org> [Sun, 25 Mar 2018 11:30:59 +0900] rev 37122
commandserver: rewrite protectio/restoreio to not depend on ui
Prepares for porting to utils.procutil, in which ui shouldn't be known.
ui.flush() is replaced with ui.fout.flush() since ui.ferr wasn't involved.
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 14:54:15 +0900] rev 37121
util: deprecate procutil proxy functions (API)
Several functions are re-exported by utils.procutil, which require explicit
modname parameter.
.. api::
Utility functions related to process/executable management have been moved
to utils.procutil module.
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 15:10:51 +0900] rev 37120
procutil: bulk-replace function calls to point to new module
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 15:09:33 +0900] rev 37119
procutil: bulk-replace util.std* to point to new module
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 13:38:04 +0900] rev 37118
procutil: move process/executable management functions to new module
std* files, pipe helpers, and findexe()s are moved as well since they are
likely to be used with sub processes.
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 14:32:34 +0900] rev 37117
util: stop using readfile() in tempfilter()
To unblock code move to utils.*. It's merely two lines of very Pythonic code.
No helper function should be needed.
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 14:38:34 +0900] rev 37116
util: mark filtertable as private constant
Prepares for porting to utils.*.
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 17:04:43 +0900] rev 37115
util: mark platform-specific gethgcmd() as private
util.hgcmd() is the public interface for gethgcmd().
Matt Harbison <matt_harbison@yahoo.com> [Sat, 24 Mar 2018 22:10:58 -0400] rev 37114
test-pathconflicts-merge: stop requiring symlink support
The errors from the last time I took a shot at this back in early November have
disappeared, so let's just enable this.
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 17:50:54 -0800] rev 37113
commands: use constants for merge things
We have nice constants now. Let's use them to make the code
easier to reason about.
Differential Revision: https://phab.mercurial-scm.org/D2702
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 18:10:36 -0800] rev 37112
merge: use constants for actions
We finish up establishing named constants in this file with
actions.
I remember scratching my head trying to figure out what this
code was doing as part of addressing a recent security issue with
subrepos. Having the named constants in place definitely makes
things easier to read.
I'm not convinced the new constants have the best names (I'm not
an expert in this code). But they can be changed easily enough.
Also, since these constants are internal only, we might want
to change their values to something more human readable to
facilitate debugging. Or maybe we could employ an enum type
some day...
Differential Revision: https://phab.mercurial-scm.org/D2701
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 14:21:57 -0500] rev 37111
merge: use constants for merge record state
Named constants are easier to read than short string values.
Differential Revision: https://phab.mercurial-scm.org/D2700
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 14:15:31 -0500] rev 37110
merge: use constants for merge driver state
Named constants are superior to magic values.
Differential Revision: https://phab.mercurial-scm.org/D2699
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 14:09:23 -0500] rev 37109
merge: use constants for merge state record types
merge.py is using multiple discrete sets of 1 and 2 letter constants
to define types and behavior. To the uninitiated, the code is very
difficult to reason about. I didn't even realize there were multiple
sets of constants in play initially!
We begin our sanity injection with merge state records. The record
types (which are serialized to disk) are now defined in RECORD_*
constants.
Differential Revision: https://phab.mercurial-scm.org/D2698
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 00:28:40 -0500] rev 37108
histedit: always define update results
Before, we had a branch that could return None for the update stats.
Let's just return an updateresult instance instead.
Differential Revision: https://phab.mercurial-scm.org/D2693
Gregory Szorc <gregory.szorc@gmail.com> [Mon, 05 Mar 2018 00:02:13 -0500] rev 37107
merge: return an attrs class from update() and applyupdates()
Previously, we returned a tuple containing counts. The result of an
update is kind of complex and the use of tuples with nameless fields
made the code a bit harder to read and constrained future expansion
of the return value.
Let's invent an attrs-defined class for representing the result of
an update operation.
We provide __getitem__ and __len__ implementations for backwards
compatibility as a container type to minimize code churn.
In (at least) Python 2, the % operator seems to insist on using
tuples. So we had to update a consumer using the % operator.
.. api::
merge.update() and merge.applyupdates() now return a class
with named attributes instead of a tuple. Switch consumers
to access elements by name instead of by offset.
Differential Revision: https://phab.mercurial-scm.org/D2692
Sangeet Kumar Mishra <mail2sangeetmishra@gmail.com> [Fri, 23 Feb 2018 11:48:58 +0530] rev 37106
histedit: make histedit's commands accept revsets (
issue5746)
Earlier the code was only looking for rulehashes and neglecting
all other revision identifiers, this code intercepts the fromrule function
and calls scmutil.revsingle() on anything that is not a rulehash and then
obtains the rulehash from the changectx object returned, rest of the pipeline
follows as it was
Differential Revision: https://phab.mercurial-scm.org/D2394
Yuya Nishihara <yuya@tcha.org> [Sat, 17 Mar 2018 17:54:33 +0900] rev 37105
formatter: make 'originalnode' a thing in log-like templates
mapping['node'] doesn't work since {node} is computed dynamically in non-web
templates.
Yuya Nishihara <yuya@tcha.org> [Sat, 17 Mar 2018 17:41:07 +0900] rev 37104
formatter: port handling of 'originalnode' to populatemap() hook
This isn't a pure templating business, so let's move out of the templater
module.
Note that this works only in web templates where mapping['node'] is a static
value.
Yuya Nishihara <yuya@tcha.org> [Thu, 15 Mar 2018 21:52:47 +0900] rev 37103
templater: switch 'revcache' based on new mapping items
It was pretty easy to leave a stale 'revcache' when switching 'ctx'.
Let's make it be automatically replaced.
Yuya Nishihara <yuya@tcha.org> [Thu, 15 Mar 2018 21:49:33 +0900] rev 37102
templater: add hook point to populate additional mapping items
The 'revcache' dict will be inserted by this hook.
Matt Harbison <matt_harbison@yahoo.com> [Sat, 24 Mar 2018 01:30:50 -0400] rev 37101
context: skip path conflicts by default when clearing unknown file (
issue5776)
Prior to adding path conflict checking in
989e884d1be9, the test-audit-path.t
tests failed as shown here (but it was globbed away).
989e884d1be9 made it fail
with a message about the destination manifest containing a conflict (though the
no-symlink case wasn't updated). When the path conflict checking was gated
behind an experimental config in
2a774cae3a03^::
2a774cae3a03, the update started
erroneously succeeding here. It turns out that the child of
989e884d1be9 is the
origin of this change when path conflict checking is disabled, as shown by
grafting the experimental config range on top of it.
What's happening here is merge.batchget() is writing the symlink 'back' to wdir
(but as a regular file for the no-symlink case), and then tries to write
'back/test', but calls wctx['back/test'].clearunknown() first. The code that's
gated here was removing the newly written 'back' file, allowing 'back/test' to
succeed. I tried checking for the dir components of 'back/test' in dirstate,
and skipping removal if present. But that didn't work because the dirstate
isn't updated after each file is written out.
This is the last persistent test failure on Windows, so the testbot should start
turning green now. \o/
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 13:02:27 +0900] rev 37100
url: make logginghttphandler compatible with Python 2.7.6
There wasn't a usable hook point in httplib, so we have to replace connect()
to wrap the socket before self._tunnel().
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 14:24:32 +0900] rev 37099
util: make safehasattr() a pycompat function
So safehasattr() can be imported by utils.* modules. util.safehasattr() still
remains as an alias since it is pretty basic utility available for years.
On current Python 3, the builtin hasattr() should have no problem.
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 14:13:37 +0900] rev 37098
util: drop util.Abort in favor of error.Abort (API)
IIRC, error.Abort exists since Mercurial 1.2, so it should be pretty easy
for extensions authors to update their code.
.. api::
The util.Abort alias has been removed. Use error.Abort.
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 14:09:44 +0900] rev 37097
test-bundle2-exchange: use error.Abort instead of util.Abort
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 14:08:50 +0900] rev 37096
util: use error.Abort instead of local alias
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 13:30:50 +0900] rev 37095
rcutil: directly call win32.executablepath()
Since it isn't supported on POSIX platform, we don't need to double the
compatibility layers.
Yuya Nishihara <yuya@tcha.org> [Sat, 24 Mar 2018 17:19:32 +0900] rev 37094
directaccess: do not abort by 'ff...' hash
Since the 'ff...' hash should never be hidden, we can just ignore it.
Gregory Szorc <gregory.szorc@gmail.com> [Fri, 23 Mar 2018 11:20:13 -0700] rev 37093
hgweb: don't responsd to api requests unless feature is enabled
Per discussion at https://phab.mercurial-scm.org/D2834, new URLs
in hgweb can conflict with subrepos and virtual repos. This may prevent
access to repos in certain paths or having certain names.
Until we have a workaround for this, let's not serve requests for
"api/" URLs unless the feature is enabled.
Differential Revision: https://phab.mercurial-scm.org/D2936
Daniel Ploch <dploch@google.com> [Fri, 23 Mar 2018 11:20:49 -0700] rev 37092
fancyopts: prevent mutation of the default value in customopts
Differential Revision: https://phab.mercurial-scm.org/D2937