Tue, 14 Jun 2011 23:26:35 +0200 import: add --bypass option
Patrick Mezard <pmezard@gmail.com> [Tue, 14 Jun 2011 23:26:35 +0200] rev 14611
import: add --bypass option This feature is more a way to test patching without a working directory than something people asked about. Adding a --rev option to specify the parent patch revision would make it a little more useful. What this change introduces is patch.repobackend class which let patches be applied against repository revisions. The caller must supply a filestore object to receive patched content, which can be turned into a memctx with patch.makememctx() helper.
Tue, 14 Jun 2011 23:24:40 +0200 import: separate parents selection from working dir update
Patrick Mezard <pmezard@gmail.com> [Tue, 14 Jun 2011 23:24:40 +0200] rev 14610
import: separate parents selection from working dir update This will be useful when patching without updating the dirstate
Tue, 14 Jun 2011 23:24:34 +0200 patch: extend filtestore to store an optional copy source
Patrick Mezard <pmezard@gmail.com> [Tue, 14 Jun 2011 23:24:34 +0200] rev 14609
patch: extend filtestore to store an optional copy source This will help wrapping filestores in memctx.
Tue, 14 Jun 2011 16:38:34 +0200 paper/coal: use fixed width for diffstat +/- link
Martin Geisler <mg@aragost.com> [Tue, 14 Jun 2011 16:38:34 +0200] rev 14608
paper/coal: use fixed width for diffstat +/- link The plus and minus characters are normally not the same width in a non-monospace font, and this made the line length change when the diffstat display was toggled. The square brackets are not rendered in a monospace font to ensure that they align with the parenthesis on the same line.
Tue, 14 Jun 2011 16:33:46 +0200 hg: rename opts argument to peeropts in clone
Martin Geisler <mg@aragost.com> [Tue, 14 Jun 2011 16:33:46 +0200] rev 14607
hg: rename opts argument to peeropts in clone This should make it clearer that the options are used with remoteui only and are not used otherwise in hg.clone.
Mon, 13 Jun 2011 16:25:18 -0500 hg: move peerschemes back to schemes
Matt Mackall <mpm@selenic.com> [Mon, 13 Jun 2011 16:25:18 -0500] rev 14606
hg: move peerschemes back to schemes This will avoid breaking things with extensions until peers are fully separated from repos.
Mon, 13 Jun 2011 14:53:23 -0500 hg: rearrange peer scheme lookup
Matt Mackall <mpm@selenic.com> [Mon, 13 Jun 2011 14:53:23 -0500] rev 14605
hg: rearrange peer scheme lookup There is now only peer scheme lookup. Repository lookup goes through peer scheme lookup. When peer and repo types are finally separated, repo lookup will use peer.local() to get a repository object. The underbar is dropped so that extensions can patch the table.
Mon, 13 Jun 2011 14:56:00 +0300 forget, remove: don't note on nonexistent file twice
Idan Kamara <idankk86@gmail.com> [Mon, 13 Jun 2011 14:56:00 +0300] rev 14604
forget, remove: don't note on nonexistent file twice before: $ hg forget foo foo: No such file or directory not removing foo: file is already untracked after: $ hg forget foo foo: No such file or directory
Mon, 13 Jun 2011 12:51:38 -0500 localrepo: local() returns self
Matt Mackall <mpm@selenic.com> [Mon, 13 Jun 2011 12:51:38 -0500] rev 14603
localrepo: local() returns self Temporary measure for introducing peers
Mon, 13 Jun 2011 12:51:37 -0500 tests: avoid instability in test-convert-cvs-synthetic
Matt Mackall <mpm@selenic.com> [Mon, 13 Jun 2011 12:51:37 -0500] rev 14602
tests: avoid instability in test-convert-cvs-synthetic
Mon, 13 Jun 2011 00:19:26 +0300 dispatch: propagate ui command options to the local ui (issue2523)
Idan Kamara <idankk86@gmail.com> [Mon, 13 Jun 2011 00:19:26 +0300] rev 14601
dispatch: propagate ui command options to the local ui (issue2523) so the ui object passed to pre/post python hooks has the verbose flag (and the rest) set correctly
Sun, 12 Jun 2011 23:30:39 +0300 mq: catch correct exception when calling changelog.rev()
Idan Kamara <idankk86@gmail.com> [Sun, 12 Jun 2011 23:30:39 +0300] rev 14600
mq: catch correct exception when calling changelog.rev()
Sun, 12 Jun 2011 17:26:58 +0300 rebase: preserve mq series order after rebasing (issue2849)
Idan Kamara <idankk86@gmail.com> [Sun, 12 Jun 2011 17:26:58 +0300] rev 14599
rebase: preserve mq series order after rebasing (issue2849)
Sun, 12 Jun 2011 17:26:20 +0300 run-tests: verbose log ignored test
Idan Kamara <idankk86@gmail.com> [Sun, 12 Jun 2011 17:26:20 +0300] rev 14598
run-tests: verbose log ignored test
Fri, 10 Jun 2011 10:58:10 +0200 record: add white space diff options
Ingo Proetel <proetel@aicas.de> [Fri, 10 Jun 2011 10:58:10 +0200] rev 14597
record: add white space diff options
Mon, 13 Jun 2011 13:53:58 +0200 mq: rename abort_if_wdir_patched to abortifwdirpatched
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:53:58 +0200] rev 14596
mq: rename abort_if_wdir_patched to abortifwdirpatched
Mon, 13 Jun 2011 13:48:47 +0200 mq: rename partial_name to partialname
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:48:47 +0200] rev 14595
mq: rename partial_name to partialname
Mon, 13 Jun 2011 13:47:21 +0200 mq: rename write_list to writelist
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:47:21 +0200] rev 14594
mq: rename write_list to writelist
Mon, 13 Jun 2011 13:45:48 +0200 mq: rename series_dirty to seriesdirty
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:45:48 +0200] rev 14593
mq: rename series_dirty to seriesdirty
Mon, 13 Jun 2011 13:44:34 +0200 mq: rename applied_dirty to applieddirty
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:44:34 +0200] rev 14592
mq: rename applied_dirty to applieddirty
Mon, 13 Jun 2011 13:43:03 +0200 mq: rename guards_dirty to guardsdirty
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:43:03 +0200] rev 14591
mq: rename guards_dirty to guardsdirty
Mon, 13 Jun 2011 13:41:58 +0200 mq: rename active_guards to activeguards
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:41:58 +0200] rev 14590
mq: rename active_guards to activeguards
Mon, 13 Jun 2011 13:40:35 +0200 mq: rename guards_path to guardspath
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:40:35 +0200] rev 14589
mq: rename guards_path to guardspath
Mon, 13 Jun 2011 13:39:14 +0200 mq: rename status_path to statuspath
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:39:14 +0200] rev 14588
mq: rename status_path to statuspath
Mon, 13 Jun 2011 13:38:04 +0200 mq: rename series_path to seriespath
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 13:38:04 +0200] rev 14587
mq: rename series_path to seriespath
Mon, 13 Jun 2011 12:11:49 +0200 mq: rename series_end to seriesend
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:11:49 +0200] rev 14586
mq: rename series_end to seriesend
Mon, 13 Jun 2011 12:09:29 +0200 mq: rename full_series_end to fullseriesend
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:09:29 +0200] rev 14585
mq: rename full_series_end to fullseriesend
Mon, 13 Jun 2011 12:07:46 +0200 mq: rename check_reserved_name to checkreservedname
Adrian Buehlmann <adrian@cadifra.com> [Mon, 13 Jun 2011 12:07:46 +0200] rev 14584
mq: rename check_reserved_name to checkreservedname
(0) -10000 -3000 -1000 -300 -100 -50 -28 +28 +50 +100 +300 +1000 +3000 +10000 +30000 tip