Patrick Mezard <pmezard@gmail.com> [Thu, 20 Oct 2011 16:43:31 +0200] rev 15322
mq: avoid data loss upon qfold + qmv (
issue3058)
When renaming a patch A as B where B was previously qfolded into A and
therefore marked as removed, a versioned MQ would first restore B before
marking it as a copy of A, thus losing A changes. The undelete() call is
probably a left-over, wctx.copy() explicitely handles the case where the
destination is removed.
Also note that status command represents "hg rm b; hg mv a b" as:
A b
a
R a
which explains the first hunk in test-mq-qrename.t.
Martin Geisler <mg@lazybytes.net> [Fri, 21 Oct 2011 00:33:08 +0200] rev 15321
subrepos: abort commit by default if a subrepo is dirty (BC)
This changeset flips the default value of ui.commitsubrepos setting
from True to False and adds a --subrepos flag to commit.
The commit, status, and diff commands behave like this with regard to
recusion and the ui.commitsubrepos setting:
| recurses | recurses
| by default | with --subrepos
--------+---------------+----------------
commit: | commitsubrepo | True
status: | False | True
diff: | False | True
By changing the default from True to False, the table becomes
consistent in the two columns:
* without --subrepos on the command line, commit will abort if a
subrepo is dirty and status/diff wont show changes inside subrepos.
* with --subrepos, all three commands will recurse.
A --subrepos flag on the command line overrides the config settin.g
Benjamin Pollack <benjamin@bitquabit.com> [Thu, 20 Oct 2011 17:05:13 -0400] rev 15320
largefiles: use XDG and OS X-specific cache locations by default (
issue3067)
Benjamin Pollack <benjamin@bitquabit.com> [Wed, 19 Oct 2011 20:40:55 -0400] rev 15319
largefiles: remove redundant any_ function
Eli Carter <eli.carter@tektronix.com> [Thu, 20 Oct 2011 09:35:37 -0500] rev 15318
largefiles: testcase to simulate inter-user clone on local machine
Benjamin Pollack <benjamin@bitquabit.com> [Thu, 20 Oct 2011 13:24:11 -0400] rev 15317
largefiles: make the store primary, and the user cache secondary
This uses the now-properly-named functions and methods from the previous
patch to actually deliver the desired behavior
Benjamin Pollack <benjamin@bitquabit.com> [Thu, 20 Oct 2011 13:24:09 -0400] rev 15316
largefiles: rename functions and methods to match desired behavior
The original intent was that the largefiles would primarily be in the
repository, with the global cache being only that--a cache. The naming
conventions and actual intent have both strayed. In this first patch, the
naming conventions are switched to match the actual intent, as are the
configuration options.
Benjamin Pollack <benjamin@bitquabit.com> [Thu, 20 Oct 2011 13:24:08 -0400] rev 15315
largefiles: fix documentation to match desired behavior
Martin Geisler <mg@aragost.com> [Thu, 20 Oct 2011 17:47:33 +0200] rev 15314
runrst: improve error message when Docutils is missing
Peter Toft told me he had installed a 'python-doc' package instead of
the correct 'python-docutils' and he suggested that we add the URL to
Docutils in our error message.
Eli Carter <eli.carter@tektronix.com> [Tue, 18 Oct 2011 17:28:26 -0500] rev 15313
largefiles: fix newline for lfconverted repos
Eli Carter <eli.carter@tektronix.com> [Wed, 19 Oct 2011 15:37:03 -0500] rev 15312
largefiles: remove 1.9 compat code
Matt Mackall <mpm@selenic.com> [Wed, 19 Oct 2011 17:16:25 -0500] rev 15311
merge with i18n
Wagner Bruna <wbruna@softwareexpress.com.br> [Tue, 18 Oct 2011 09:51:02 -0200] rev 15310
i18n-pt_BR: synchronized with
ab341fbb05b1
Wagner Bruna <wbruna@softwareexpress.com.br> [Tue, 18 Oct 2011 09:50:57 -0200] rev 15309
i18n-pt_BR: msgmerge with
ab341fbb05b1
Wagner Bruna <wbruna@softwareexpress.com.br> [Tue, 18 Oct 2011 09:38:14 -0200] rev 15308
bisect: add i18n contexts
Wagner Bruna <wbruna@softwareexpress.com.br> [Tue, 18 Oct 2011 09:38:10 -0200] rev 15307
import: add i18n context
Greg Ward <greg@gerg.ca> [Sun, 16 Oct 2011 10:24:45 -0400] rev 15306
largefiles: fix some badly named function parameters
overrides.py contains several functions that temporarily override
scmutil.match(), which always takes a changectx object as the first
parameter. But these overrides name that parameter either 'repo' or
'ctxorrepo', which is misleading. So rename them to 'ctx' and remove
the special type-sensitive handling of the one called 'ctxorrepo'.
Greg Ward <greg@gerg.ca> [Sun, 16 Oct 2011 10:29:51 -0400] rev 15305
largefiles: tidy imports
- no need to defensively import scmutil
- remove duplicate
- unwrap non-long line
Greg Ward <greg@gerg.ca> [Tue, 18 Oct 2011 20:06:23 -0400] rev 15304
largefiles: rename config setting 'size' to 'minsize'
Eli Carter <eli.carter@tektronix.com> [Tue, 18 Oct 2011 16:40:59 -0500] rev 15303
largefiles: include 'largefiles' in converted repository requirements
Hao Lian <hao@fogcreek.com> [Tue, 18 Oct 2011 17:09:03 -0400] rev 15302
largefiles: string formatting typo in basestore._openstore where comma is used instead of modulo
Eli Carter <eli.carter@tektronix.com> [Tue, 18 Oct 2011 11:09:11 -0500] rev 15301
largefiles: fix test typo
Eli Carter <eli.carter@tektronix.com> [Tue, 18 Oct 2011 10:32:12 -0500] rev 15300
convert: fix typo
Eli Carter <eli.carter@tektronix.com> [Tue, 18 Oct 2011 09:59:04 -0500] rev 15299
largefiles: fix typo
Na'Tosha Bard <natosha@unity3d.com> [Wed, 19 Oct 2011 17:40:27 +0200] rev 15298
largefiles: test that merging does not result in wrong versions of largefiles
Na'Tosha Bard <natosha@unity3d.com> [Wed, 19 Oct 2011 17:02:59 +0200] rev 15297
largefiles: expand test suite some more (test rebasing, rollback, update --clean, and verify --large)
Matt Mackall <mpm@selenic.com> [Mon, 17 Oct 2011 17:27:33 -0500] rev 15296
check-code: report suspicious string joins
This detects patterns of the form:
ui.write("this is missing"
"a space at the join\n")
Wagner Bruna <wbruna@softwareexpress.com.br> [Mon, 17 Oct 2011 19:10:28 -0200] rev 15295
largefiles: fix typo