Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 17:47:04 -0500] rev 5458
mpatch: use int rather than ssize_t
We might need to be more clever than this to make Py2.5 happy.
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 17:46:06 -0500] rev 5457
osutil: improve portability
- manually inline mode_to_kind
- remove unused alloca include
- remove fstatat and associated bits
It's not obvious that there's an advantage to using fstatat in terms
of performance. The race-avoidance properties of fstatat aren't
terribly useful to us either. So best to avoid it until we figure out
how to use it portably.
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Thu, 11 Oct 2007 16:28:30 +0200] rev 5456
fix typo
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Thu, 11 Oct 2007 16:26:14 +0200] rev 5455
import gettext since '_' is used
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Thu, 11 Oct 2007 16:19:12 +0200] rev 5454
explicitely use integer division
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Thu, 11 Oct 2007 12:16:55 +0200] rev 5453
fix UnboundLocalError, refactor a bit
bin wasn't defined in all branches (bug introduced in
82b4ff3abbcd
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:56 -0500] rev 5452
bdiff: tweaks for large files
- adjust the common line threshold to .1%
this speeds up a delta of 7M lines of source from 10m to 40s
- adjust the scaling of the hash array down a bit as it was raising the peak
memory usage significantly
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:54 -0500] rev 5451
revlog: break up compression of large deltas
Python's zlib apparently makes an internal copy of strings passed to
compress(). To avoid this, compress strings 1M at a time, then join
them at the end if the result would be smaller than the original.
For initial commits of large but compressible files, this cuts peak
memory usage nearly in half.
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:53 -0500] rev 5450
revlog: fix caching of buffer objects
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:52 -0500] rev 5449
chunkiter: handle large reads more efficiently
- for large reads, don't attempt to read more than necessary
- if we've gathered the exact number of bytes needed, avoid a string copy
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:51 -0500] rev 5448
revlog: avoid large yields in group()
Split large yields so that the downstream consumer (chunkbuffer) will avoid
some pain when reading ahead.
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:49 -0500] rev 5447
chunkiter: simplify iter logic
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:48 -0500] rev 5446
chunkbuffer: removed unused method and arg
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:47 -0500] rev 5445
revlog: reduce memory usage in addgroup
- use a buffer to extract the delta from a chunk
- avoid concatenating to a compressed delta
- use a buffer to directly extra full text from a trivial delta
- delete chunk and delta objects after use
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:45 -0500] rev 5444
mpatch: allow buffer objects for input
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:40 -0500] rev 5443
Merge with crew
Those crew folks are getting lazy about pulling from upstream before
committing.
Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 15:48:08 -0700] rev 5442
test-convert-darcs: don't let $HOME/.darcs pollute the test environment
Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 15:42:00 -0700] rev 5441
convert: refactor sink initialisation, to remove hardcoding of hg
We also introduce options to explicitly set the source and destination
repository types.
Improve testing of corner cases a little.
Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 15:30:00 -0700] rev 5440
convert: add default constructor for converter_sink
Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 15:30:00 -0700] rev 5439
convert: make contents of "extra" dict available from sources, for sinks.
This breaks hash preservation for hg->hg conversion, as each converted
change gets a convert_revision item added to its extra dict. Ugh.
Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 15:30:00 -0700] rev 5438
convert: rename convert_svn to svn_source
Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 00:15:33 -0700] rev 5437
convert: report errors more meaningfully if run with --traceback
Matt Mackall <mpm@selenic.com> [Tue, 09 Oct 2007 17:44:44 -0500] rev 5436
Merge with crew
Bryan O'Sullivan <bos@serpentine.com> [Tue, 09 Oct 2007 08:39:37 -0700] rev 5435
osutil: Solaris build fix
Matt Mackall <mpm@selenic.com> [Tue, 09 Oct 2007 17:25:24 -0500] rev 5434
Merge with -stable
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:22 -0500] rev 5433
findcopies: fix rename bug
We've fiddled with this line several times, and an old bug has
reappeared from it. Let's take a peek at the history.
The original "or" (rev 3674, in 0.9.2 and 0.9.3):
http://www.selenic.com/hg/rev/
9103dab96093
Then I changed it to an "and" to fix a bug (rev 4304):
http://www.selenic.com/hg/rev/
4787e2b0dd03
Then for reasons now lost in the mists of time, I dropped half (rev 4399):
http://www.selenic.com/hg/rev/
93652499bed3
Then we added back the "or" (rev 4416, in 0.9.4):
http://www.selenic.com/hg/rev/
bb1800a7d7e1
So it seems it ought to be "and".
Matt Mackall <mpm@selenic.com> [Tue, 09 Oct 2007 17:22:38 -0500] rev 5432
mq: clarify queue top message
Bryan O'Sullivan <bos@serpentine.com> [Mon, 08 Oct 2007 22:45:48 -0700] rev 5431
Fix build error with Sun C compiler.
Alexis S. L. Carvalho <alexis@cecm.usp.br> [Mon, 08 Oct 2007 21:37:25 -0300] rev 5430
osutil.c: use strncpy instead of strncat
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:22 -0500] rev 5429
findcopies: fix rename bug
We've fiddled with this line several times, and an old bug has
reappeared from it. Let's take a peek at the history.
The original "or" (rev 3674, in 0.9.2 and 0.9.3):
http://www.selenic.com/hg/rev/
9103dab96093
Then I changed it to an "and" to fix a bug (rev 4304):
http://www.selenic.com/hg/rev/
4787e2b0dd03
Then for reasons now lost in the mists of time, I dropped half (rev 4399):
http://www.selenic.com/hg/rev/
93652499bed3
Then we added back the "or" (rev 4416, in 0.9.4):
http://www.selenic.com/hg/rev/
bb1800a7d7e1
So it seems it ought to be "and".