Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 15:30:00 -0700] rev 5439
convert: make contents of "extra" dict available from sources, for sinks.
This breaks hash preservation for hg->hg conversion, as each converted
change gets a convert_revision item added to its extra dict. Ugh.
Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 15:30:00 -0700] rev 5438
convert: rename convert_svn to svn_source
Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 00:15:33 -0700] rev 5437
convert: report errors more meaningfully if run with --traceback
Matt Mackall <mpm@selenic.com> [Tue, 09 Oct 2007 17:44:44 -0500] rev 5436
Merge with crew
Bryan O'Sullivan <bos@serpentine.com> [Tue, 09 Oct 2007 08:39:37 -0700] rev 5435
osutil: Solaris build fix
Matt Mackall <mpm@selenic.com> [Tue, 09 Oct 2007 17:25:24 -0500] rev 5434
Merge with -stable
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:22 -0500] rev 5433
findcopies: fix rename bug
We've fiddled with this line several times, and an old bug has
reappeared from it. Let's take a peek at the history.
The original "or" (rev 3674, in 0.9.2 and 0.9.3):
http://www.selenic.com/hg/rev/
9103dab96093
Then I changed it to an "and" to fix a bug (rev 4304):
http://www.selenic.com/hg/rev/
4787e2b0dd03
Then for reasons now lost in the mists of time, I dropped half (rev 4399):
http://www.selenic.com/hg/rev/
93652499bed3
Then we added back the "or" (rev 4416, in 0.9.4):
http://www.selenic.com/hg/rev/
bb1800a7d7e1
So it seems it ought to be "and".
Matt Mackall <mpm@selenic.com> [Tue, 09 Oct 2007 17:22:38 -0500] rev 5432
mq: clarify queue top message
Bryan O'Sullivan <bos@serpentine.com> [Mon, 08 Oct 2007 22:45:48 -0700] rev 5431
Fix build error with Sun C compiler.
Alexis S. L. Carvalho <alexis@cecm.usp.br> [Mon, 08 Oct 2007 21:37:25 -0300] rev 5430
osutil.c: use strncpy instead of strncat
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:22 -0500] rev 5429
findcopies: fix rename bug
We've fiddled with this line several times, and an old bug has
reappeared from it. Let's take a peek at the history.
The original "or" (rev 3674, in 0.9.2 and 0.9.3):
http://www.selenic.com/hg/rev/
9103dab96093
Then I changed it to an "and" to fix a bug (rev 4304):
http://www.selenic.com/hg/rev/
4787e2b0dd03
Then for reasons now lost in the mists of time, I dropped half (rev 4399):
http://www.selenic.com/hg/rev/
93652499bed3
Then we added back the "or" (rev 4416, in 0.9.4):
http://www.selenic.com/hg/rev/
bb1800a7d7e1
So it seems it ought to be "and".
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:21 -0500] rev 5428
osutil: more tidying
- do_stat -> keep_stat
- all_kinds -> !need_stat
- simplify main error logic
- reorder declarations
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:18 -0500] rev 5427
osutil: move file list loop to its own function
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:17 -0500] rev 5426
osutil: simplify DT_REG support
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:16 -0500] rev 5425
osutils: pull file stat loop into its own function
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:15 -0500] rev 5424
osutil: fold stat paths together
- simplify st/py_st logic
- use stp to point to stat buffer
- combine stat paths
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:14 -0500] rev 5423
osutil: more cleanups
- eliminate a level of nesting
- untab targets of gotos
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:12 -0500] rev 5422
osutil: eliminate alloca call
- make full_path a PATH_MAX + epsilon local buffer
- use strncpy and strncat
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:06 -0500] rev 5421
osutil: cleanups
- use tabs
- eliminate old-style function pointer calls
- eliminate weird scoping
- eliminate assignment-in-iff
- use !foo rather than foo == NULL
Rafael Villar Burke <pachi@rvburke.com> [Fri, 05 Oct 2007 01:52:53 +0200] rev 5420
Execution bit detection fixes for VFAT on Linux
On Linux VFAT execution mode can be modified, but changes don't
persist a filesy stem remount. The current test can be trickled by
this. We can help with the det ection of VFAT checking whether new
files get created with the execution bits on
(as usually these partitions are mounted with the exec option, for
convenience)
.
Christian Ebert <blacktrash@gmx.net> [Wed, 12 Sep 2007 12:54:36 +0200] rev 5419
churn: simplify code to get terminal width
Patrick Mezard <pmezard@gmail.com> [Mon, 08 Oct 2007 22:20:23 +0200] rev 5418
patch: fix git sendmail handling without proper mail headers
TK Soh <teekaysoh@yahoo.com> [Mon, 08 Oct 2007 11:18:34 +0800] rev 5417
hgk: allow any extdiff command for visual diff
Giorgos Keramidas <keramida@ceid.upatras.gr> [Sun, 07 Oct 2007 21:56:36 +0300] rev 5416
osutil.c: style fix - delete trailing end-of-line spaces
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Sun, 07 Oct 2007 20:45:10 +0200] rev 5415
convert: do not output when trying to load svn bindings
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Sun, 07 Oct 2007 20:44:54 +0200] rev 5414
convert: split converters into sink/source
Patrick Mezard <pmezard@gmail.com> [Sun, 07 Oct 2007 19:03:32 +0200] rev 5413
Test darcs converter
Patrick Mezard <pmezard@gmail.com> [Sun, 07 Oct 2007 18:59:03 +0200] rev 5412
convert: fix darcs_source.pull() under windows
Patrick Mezard <pmezard@gmail.com> [Sun, 07 Oct 2007 18:58:54 +0200] rev 5411
convert: fix darcs_source._run() under windows
Patrick Mezard <pmezard@gmail.com> [Sun, 07 Oct 2007 18:58:44 +0200] rev 5410
hghave: detect darcs client
Patrick Mezard <pmezard@gmail.com> [Sun, 07 Oct 2007 18:58:36 +0200] rev 5409
hghave: reorder check functions and entries
Patrick Mezard <pmezard@gmail.com> [Sun, 07 Oct 2007 15:13:50 +0200] rev 5408
Test workingctx exec/link bit for copies.
Also, make the test runnable on platforms without symlinks.