Mon, 02 Apr 2018 09:18:01 -0700 context: drop support for changeid='' (API)
Martin von Zweigbergk <martinvonz@google.com> [Mon, 02 Apr 2018 09:18:01 -0700] rev 37267
context: drop support for changeid='' (API) Since the previous commit, there seem to be no users who pass '' to repo.__getitem__, so let's drop support for it. It may seem like a small cost to keep support for it, but I've spent time being confused by it twice already. Differential Revision: https://phab.mercurial-scm.org/D3021
Mon, 02 Apr 2018 08:43:08 -0700 subrepo: use repo['.'] instead of repo['']
Martin von Zweigbergk <martinvonz@google.com> [Mon, 02 Apr 2018 08:43:08 -0700] rev 37266
subrepo: use repo['.'] instead of repo[''] The "state" value (a revision) passed to abstractsubrepo.phase() can be '' to represent the currently checked out revisions. Let's convert that to the more common '.'. I think this is the last of use of repo['.'] in core. Differential Revision: https://phab.mercurial-scm.org/D3019
Tue, 03 Apr 2018 00:12:29 +0530 children: use repo['.'] instead of repo['']
Martin von Zweigbergk <martinvonz@google.com> [Tue, 03 Apr 2018 00:12:29 +0530] rev 37265
children: use repo['.'] instead of repo[''] Differential Revision: https://phab.mercurial-scm.org/D3020
Mon, 02 Apr 2018 09:16:52 -0700 revset: drop support for '' as alias for '.'
Martin von Zweigbergk <martinvonz@google.com> [Mon, 02 Apr 2018 09:16:52 -0700] rev 37264
revset: drop support for '' as alias for '.' Not marked BC because I think support for using '' on the CLI was there by accident, and we don't seem to have documented it. Differential Revision: https://phab.mercurial-scm.org/D3018
Mon, 02 Apr 2018 09:06:24 -0700 tests: add test showing current parse of empty string symbol in revset
Martin von Zweigbergk <martinvonz@google.com> [Mon, 02 Apr 2018 09:06:24 -0700] rev 37263
tests: add test showing current parse of empty string symbol in revset We support e.g. parents(""), but I think that's by accident and I'll change it soon. Differential Revision: https://phab.mercurial-scm.org/D3017
Mon, 02 Apr 2018 08:46:07 -0700 clone: rename "rev" to "revs" since there can be many
Martin von Zweigbergk <martinvonz@google.com> [Mon, 02 Apr 2018 08:46:07 -0700] rev 37262
clone: rename "rev" to "revs" since there can be many It was a little tricky in hg.clone(), since there was a local "revs" variable defined there, but "rev" was never used after "revs", so I just overwrote it. Note that clonewithshare() should also have its "rev" argument renamed to "revs", but I'll leave that to someone else. Differential Revision: https://phab.mercurial-scm.org/D3016
Sun, 01 Apr 2018 15:41:16 -0700 parseurl: consistently call second output "branches"
Martin von Zweigbergk <martinvonz@google.com> [Sun, 01 Apr 2018 15:41:16 -0700] rev 37261
parseurl: consistently call second output "branches" Differential Revision: https://phab.mercurial-scm.org/D3015
Sun, 01 Apr 2018 11:06:29 +0900 templatefuncs: do not crash because of invalid value fed to mailmap()
Yuya Nishihara <yuya@tcha.org> [Sun, 01 Apr 2018 11:06:29 +0900] rev 37260
templatefuncs: do not crash because of invalid value fed to mailmap()
Sat, 31 Mar 2018 23:34:15 -0700 scmutil: deprecate revpairnodes()
Martin von Zweigbergk <martinvonz@google.com> [Sat, 31 Mar 2018 23:34:15 -0700] rev 37259
scmutil: deprecate revpairnodes() Differential Revision: https://phab.mercurial-scm.org/D3012
Sun, 01 Apr 2018 09:30:44 -0700 tests: use context-return revpair() in autodiff
Martin von Zweigbergk <martinvonz@google.com> [Sun, 01 Apr 2018 09:30:44 -0700] rev 37258
tests: use context-return revpair() in autodiff Differential Revision: https://phab.mercurial-scm.org/D3013
(0) -30000 -10000 -3000 -1000 -300 -100 -10 +10 +100 +300 +1000 +3000 +10000 tip