store: use the boolean property in `repair_
issue6528`
store: introduce boolean property for revlog type
This will avoid exposing implementation details to more generic code.
store: issue a single entry for each revlog
We now yield a single entry, with data about each files involved. This help to
simplify multiple code using this and it will help to further simplify and
fixes the streaming code.
store: rename `unencoded_path` to `entry_path` for StoreEntry
This remove the ambiguity with StoreFile and make sure use code will be using
the right API.
store: do the revlog matching on entry directly
This is the last blocker to safely merge the revlog files in a single entry.
store: split the wrapping of encodedstore between _wrap and datafiles
The `datafiles` method of `basicstore` is doing a lot of work that should be
done on decoded filename. So we now wrap `_walk` to do the decoding, and less
work in `datafiles`.
This is necessary to make sure file from the same revlog can be grouped
together.