store: rename `unencoded_path` to `entry_path` for StoreEntry
This remove the ambiguity with StoreFile and make sure use code will be using
the right API.
store: do the revlog matching on entry directly
This is the last blocker to safely merge the revlog files in a single entry.
store: split the wrapping of encodedstore between _wrap and datafiles
The `datafiles` method of `basicstore` is doing a lot of work that should be
done on decoded filename. So we now wrap `_walk` to do the decoding, and less
work in `datafiles`.
This is necessary to make sure file from the same revlog can be grouped
together.
store: introduce a main_file_path method for revlog
This help code that need to point revlog to an index file. This is put to use
in the upgrade code.
upgrade: actually use StoreEntry API to create revlog
Lets make use of the semanctic of the object we are passed.
upgrade: use StoreEntry object in upgrade
We will make more use of the API in the next changeset, but just moving to use
entry is a significant change for the engine codebase.
upgrade: drop a quick fix that is not longer necessary
We won't issue bad revlog from topfile anymore.
store: use StoreEntry API instead of parsing filename in largefile
This is more explicit and more robust.
store: use StoreEntry API instead of parsing filename when listing manifestlog
This is more explicit and more robust.
store: use StoreEntry API instead of parsing filename when fixing
issue6528
This is more explicit and more robust.
We also introduce a small output change as it make things simpler and this is a
affecting a debug-command.