Mon, 25 Jul 2011 15:08:37 +0300 |
Idan Kamara |
localrepo: decorate _bookmarks/current with filecache
|
Mon, 25 Jul 2011 15:08:37 +0300 |
Idan Kamara |
localrepo: decorate changelog() with filecache
|
Mon, 25 Jul 2011 15:08:37 +0300 |
Idan Kamara |
localrepo: refresh filecache entries after releasing a repo.lock()
|
Mon, 25 Jul 2011 15:08:37 +0300 |
Idan Kamara |
localrepo: decorate dirstate() with filecache
|
Mon, 25 Jul 2011 15:08:37 +0300 |
Idan Kamara |
localrepo: add a cache with stat info for files under .hg/
|
Wed, 20 Jul 2011 18:23:06 -0400 |
Andrew Pritchard |
localrepo: make requirements attribute of newly-created repos contain a set
|
Fri, 22 Jul 2011 16:46:22 -0500 |
Matt Mackall |
localrepo: fix comment on set
|
Thu, 21 Jul 2011 14:06:55 -0500 |
Matt Mackall |
localrepo: add set method to iterate over a given revset
|
Wed, 13 Jul 2011 17:41:49 -0500 |
Matt Mackall |
subrepo: use working copy of .hgsub to filter status (issue2901)
stable
|
Fri, 01 Jul 2011 17:37:09 +0200 |
Mads Kiilerich |
util: rename the util.localpath that uses url to urllocalpath (issue2875)
stable 1.9
|
Sun, 26 Jun 2011 15:47:39 -0300 |
Wagner Bruna |
localrepo: mark progress step for translation
stable
|
Wed, 15 Jun 2011 23:15:04 +0300 |
Idan Kamara |
localrepo: don't attempt to open .hgtags twice if the error isn't ENOENT
|
Mon, 13 Jun 2011 12:51:38 -0500 |
Matt Mackall |
localrepo: local() returns self
|
Tue, 07 Jun 2011 17:02:54 -0500 |
Matt Mackall |
check-code: catch misspellings of descendant
|
Mon, 06 Jun 2011 15:17:40 -0500 |
Matt Mackall |
subrepo: be more careful with deletions of .hgsub and .hgsubstate (issue2844)
|
Sat, 04 Jun 2011 15:56:48 +0200 |
Patrick Mezard |
localrepo: add savecommitmessage() to write last-message.txt
|
Fri, 03 Jun 2011 20:23:32 +0200 |
Sune Foldager |
localrepo: simplify file bundling code and fix progress bug
|
Fri, 03 Jun 2011 20:15:06 +0200 |
Sune Foldager |
localrepo: use list comprehension instead of generators
|
Fri, 03 Jun 2011 20:12:37 +0200 |
Sune Foldager |
localrepo: add total to changeset progress in bundle/push
|
Wed, 01 Jun 2011 16:42:50 -0500 |
Matt Mackall |
merge with stable
|
Mon, 11 Apr 2011 21:44:22 +0300 |
Idan Kamara |
localrepo: don't add deleted files to list of modified/added files (issue2761)
stable
|
Mon, 04 Apr 2011 22:51:10 +0300 |
Idan Kamara |
localrepo: ignore tags to unknown nodes (issue2750)
stable
|
Mon, 14 Mar 2011 23:50:28 +0100 |
David Soria Parra |
bookmarks: do not forward merged bookmark (issue1877)
stable
|
Wed, 01 Jun 2011 12:38:46 +0200 |
Martin Geisler |
check-code: flag 0/1 used as constant Boolean expression
|
Tue, 31 May 2011 19:16:18 +0200 |
Adrian Buehlmann |
introduce new function scmutil.readrequires
|
Thu, 26 May 2011 17:15:35 -0500 |
Matt Mackall |
dirstate: rename forget to drop
|
Wed, 18 May 2011 23:26:26 +0200 |
Sune Foldager |
revlog: linearize created changegroups in generaldelta revlogs
|
Wed, 18 May 2011 19:30:17 +0200 |
Martin Geisler |
localrepo, sshrepo: use Boolean create argument in __init__
|
Mon, 16 May 2011 12:44:34 +0200 |
Sune Foldager |
revlog: get rid of defversion
|
Sun, 08 May 2011 16:41:41 -0500 |
Matt Mackall |
merge with crew
|
Sun, 08 May 2011 21:32:33 +0200 |
Sune Foldager |
revlog: support writing generaldelta revlogs
|
Sun, 08 May 2011 16:16:41 -0500 |
Matt Mackall |
merge with stable
|
Sun, 01 May 2011 13:07:00 +0200 |
Alexander Solovyov |
fix bookmarks rollback behavior
stable
|
Fri, 06 May 2011 15:22:31 +0200 |
Adrian Buehlmann |
rename util.set_flags to setflags
|
Fri, 06 May 2011 09:54:06 +0200 |
Adrian Buehlmann |
rename path_auditor to pathauditor
|
Thu, 05 May 2011 12:55:12 +0200 |
Sune Foldager |
revlog: remove support for parentdelta
|
Wed, 04 May 2011 19:27:55 +0200 |
Sune Foldager |
fix errors reported by pyflakes test
|
Mon, 02 May 2011 10:11:18 +0200 |
Dan Villiom Podlaski Christiansen |
prevent transient leaks of file handle by using new helper functions
|
Mon, 02 May 2011 19:20:29 +0200 |
Peter Arrenbrecht |
localrepo: reuse parent manifest in commitctx if no files have changed
|
Sun, 01 May 2011 19:51:28 +0200 |
Mads Kiilerich |
backout 3a3584967a93 - the "unreachable code" was apparently not unreachable
|
Sun, 01 May 2011 19:44:28 +0200 |
Sune Foldager |
merge with mpm
|
Thu, 24 Feb 2011 14:06:08 +0100 |
Mads Kiilerich |
status: remove unreachable code for status between revisions
|
Sat, 30 Apr 2011 19:01:24 +0200 |
Benoit Boissinot |
unbundler: separate delta and header parsing
|
Sun, 01 May 2011 11:12:36 +0200 |
Brodie Rao |
pushkey: add hooks for pushkey/listkeys
|
Sat, 30 Apr 2011 09:43:20 -0700 |
Brodie Rao |
url: move URL parsing functions into util to improve startup time
|
Sat, 30 Apr 2011 17:21:37 +0200 |
Peter Arrenbrecht |
discovery: drop findoutgoing and simplify findcommonincoming's api
|
Sat, 30 Apr 2011 13:59:14 +0200 |
Alexander Solovyov |
remove unused imports and variables
|
Sat, 30 Apr 2011 12:56:28 +0200 |
Dan Villiom Podlaski Christiansen |
branchcache: improve speed relative to the amount of heads
|
Fri, 29 Apr 2011 14:54:01 +0200 |
Peter Arrenbrecht |
wireproto: add test for new optional arg missing on server
|
Sun, 24 Apr 2011 20:11:05 +0200 |
Adrian Buehlmann |
changegroup: do not count closed new heads (issue2697)
|
Sat, 23 Apr 2011 00:51:25 +0300 |
Idan Kamara |
eliminate various naked except clauses
|
Wed, 20 Apr 2011 22:43:31 +0200 |
Adrian Buehlmann |
move path_auditor from util to scmutil
|
Wed, 20 Apr 2011 19:54:57 +0200 |
Adrian Buehlmann |
move opener from util to scmutil
|
Tue, 19 Apr 2011 15:19:54 +0200 |
Martin Geisler |
merge with stable
|
Tue, 19 Apr 2011 13:25:19 +0200 |
Martin Geisler |
rollback: lower-case warning issued when branch cannot be reset
stable
|
Mon, 11 Apr 2011 21:44:22 +0300 |
Idan Kamara |
localrepo: don't add deleted files to list of modified/added files (issue2761)
|
Thu, 07 Apr 2011 17:16:17 +0300 |
Idan Kamara |
tags: remove another check for valid nodes
|
Mon, 04 Apr 2011 22:51:10 +0300 |
Idan Kamara |
localrepo: ignore tags to unknown nodes (issue2750)
|
Mon, 04 Apr 2011 16:21:59 -0500 |
Matt Mackall |
misc: replace .parents()[0] with p1()
|
Mon, 04 Apr 2011 18:05:14 +0300 |
Idan Kamara |
localrepo: tighten except clause when looking rev
|
Thu, 31 Mar 2011 15:24:06 -0500 |
Matt Mackall |
changegroup: introduce bundler objects
|
Thu, 31 Mar 2011 14:25:26 -0500 |
Matt Mackall |
changegroup: combine lookup functions
|
Thu, 31 Mar 2011 13:56:05 -0500 |
Matt Mackall |
changegroup: unnest flookup
|
Wed, 30 Mar 2011 20:03:05 -0700 |
Brodie Rao |
url: refactor util.drop_scheme() and hg.localpath() into url.localpath()
|
Thu, 31 Mar 2011 10:03:24 -0500 |
Matt Mackall |
changegroup: unnest some lookup functions
|
Thu, 31 Mar 2011 09:59:56 -0500 |
Matt Mackall |
changegroup: minor ordering and renaming changes for similarity
|
Thu, 31 Mar 2011 09:56:27 -0500 |
Matt Mackall |
changegroup: remove nodeiter temporary
|
Wed, 30 Mar 2011 17:50:34 -0500 |
Matt Mackall |
changegroup: refactor prune as a filter
|
Wed, 30 Mar 2011 17:50:27 -0500 |
Matt Mackall |
changegroup: add first logic to send file header
|
Mon, 14 Mar 2011 23:50:28 +0100 |
David Soria Parra |
bookmarks: do not forward merged bookmark (issue1877)
|
Mon, 28 Mar 2011 15:54:22 +0200 |
Adrian Buehlmann |
set NOT_CONTENT_INDEXED on .hg dir (issue2694)
|
Mon, 28 Mar 2011 11:18:56 -0500 |
Matt Mackall |
changegroup: fold linkrev helper into lookup functions
|
Mon, 28 Mar 2011 11:18:56 -0500 |
Matt Mackall |
changegroup: fold filenode collector into mlookup
|
Mon, 28 Mar 2011 11:18:56 -0500 |
Matt Mackall |
changegroup: roll changegroup.collector into lookup functions
|
Mon, 28 Mar 2011 11:18:56 -0500 |
Matt Mackall |
changegroup: add revlog to the group callback
|
Mon, 28 Mar 2011 11:18:56 -0500 |
Matt Mackall |
changegroup: move sorting down into group
|
Mon, 28 Mar 2011 11:18:56 -0500 |
Matt Mackall |
changegroup: fold progress meter into callbacks
|
Mon, 28 Mar 2011 11:18:56 -0500 |
Matt Mackall |
changegroup: combine infocollect and lookup callbacks
|
Wed, 23 Mar 2011 16:06:55 +0100 |
Peter Arrenbrecht |
discovery: avoid discovery when local graph is a subset of remote
|
Wed, 23 Mar 2011 16:02:11 +0100 |
Peter Arrenbrecht |
wireproto: add getbundle() function
|
Tue, 22 Mar 2011 09:22:21 +0100 |
Peter Arrenbrecht |
wireproto: add known([id]) function
|
Tue, 22 Mar 2011 07:38:32 +0100 |
Peter Arrenbrecht |
debug: add debugwireargs to test argument passing over the wire
|
Sun, 20 Mar 2011 20:25:41 -0500 |
Matt Mackall |
changegroup: minor cleanups
|
Sun, 20 Mar 2011 20:17:57 -0500 |
Matt Mackall |
changegroup: fix leftover from delta read
|
Sun, 20 Mar 2011 20:16:51 -0500 |
Matt Mackall |
changegroup: drop expensive redundant usage of readdelta for progress
|
Sun, 20 Mar 2011 19:43:28 -0500 |
Matt Mackall |
changegroupsubset: use manifest.readfast to simplify collector
|
Sun, 20 Mar 2011 19:43:28 -0500 |
Matt Mackall |
changegroupsubset: simplify filenode_collector
|
Sun, 20 Mar 2011 19:43:28 -0500 |
Matt Mackall |
changegroupsubset: more renaming
|
Sun, 20 Mar 2011 19:43:28 -0500 |
Matt Mackall |
changegroupsubset: simplify prune
|
Sun, 20 Mar 2011 19:43:28 -0500 |
Matt Mackall |
changegroupsubset: more minor cleanups
|
Sun, 20 Mar 2011 19:43:28 -0500 |
Matt Mackall |
changegroupsubset: minor cleanups
|
Sun, 20 Mar 2011 01:16:57 +0100 |
Benoit Boissinot |
changegroupsubset: extranodes are no longer needed
|
Mon, 14 Mar 2011 20:53:55 +0100 |
David Soria Parra |
localrepo: do not update bookmarks in addchangegroup
|
Mon, 14 Mar 2011 00:10:43 +0100 |
David Soria Parra |
bookmarks: separate bookmarks update code from localrepo's pull.
|
Sun, 06 Mar 2011 15:21:50 +0100 |
Patrick Mezard |
Improve unresolved merge conflicts warning (issue2681)
stable
|
Wed, 02 Mar 2011 21:57:20 -0600 |
Steve Borho |
bookmark: fix invalidation of localrepo._bookmarkcurrent
stable
|
Mon, 21 Feb 2011 20:58:54 -0300 |
Wagner Bruna |
rollback, i18n: avoid parameterized message
stable
|
Fri, 18 Feb 2011 20:25:25 +0100 |
Adrian Buehlmann |
introduce new RequirementError (issue2649)
stable
|
Thu, 10 Feb 2011 09:03:06 +0100 |
Gilles Moris |
rollback: clarifies the message about the reverted state (issue2628)
stable
|
Thu, 03 Feb 2011 10:31:17 +0100 |
Martin Geisler |
remove unnecessary list comprehensions
|
Tue, 15 Feb 2011 22:25:48 +0100 |
Patrick Mezard |
commit: abort if a subrepo is modified and ui.commitsubrepos=no
|
Fri, 24 Dec 2010 15:23:01 +0100 |
Dan Villiom Podlaski Christiansen |
explicitly close files
|
Fri, 28 Jan 2011 13:38:34 +0100 |
Adrian Buehlmann |
fncachestore: defer updating the fncache file to a single file open
|
Fri, 28 Jan 2011 13:34:07 +0100 |
Adrian Buehlmann |
localrepo: acquire lock on stream_in
|
Fri, 11 Feb 2011 19:44:17 +0100 |
David Soria Parra |
tags: do not merge bookmarks with tags
|
Fri, 11 Feb 2011 19:36:15 +0100 |
David Soria Parra |
context: add method to return all bookmarks pointing to a node
|
Thu, 10 Feb 2011 13:46:28 -0600 |
Matt Mackall |
bookmarks: merge suspect addchangegroup into core
|
Thu, 10 Feb 2011 13:46:28 -0600 |
Matt Mackall |
bookmarks: merge low-level push/pull support into core
|
Thu, 10 Feb 2011 13:46:28 -0600 |
Matt Mackall |
bookmarks: merge lookup into localrepo
|
Thu, 10 Feb 2011 13:46:28 -0600 |
Matt Mackall |
bookmarks: merge _findtags method into core
|
Thu, 10 Feb 2011 13:46:27 -0600 |
Matt Mackall |
bookmarks: merge invalidation into core
|
Thu, 10 Feb 2011 13:46:27 -0600 |
Matt Mackall |
bookmarks: move commit action into core
|
Thu, 10 Feb 2011 13:46:27 -0600 |
Matt Mackall |
bookmarks: merge rollback support into localrepo
|
Thu, 10 Feb 2011 13:46:27 -0600 |
Matt Mackall |
bookmarks: move property methods into localrepo
|
Mon, 17 Jan 2011 09:37:20 +0100 |
Adrian Buehlmann |
remove pointless os.path.join calls when opening files in .hg/cache
|
Mon, 31 Jan 2011 22:16:33 +0100 |
Patrick Mezard |
mq: factor out push conditions checks
|
Tue, 04 Jan 2011 06:29:08 +0100 |
jfh |
move tags.cache and branchheads.cache to a collected cache folder .hg/cache/
|
Sun, 16 Jan 2011 17:26:34 +0100 |
Benoit Boissinot |
addchangegroup: document the current locking semantics
|
Tue, 04 Jan 2011 14:12:52 -0600 |
Matt Mackall |
revlog: remove lazy index
|
Thu, 02 Dec 2010 03:43:06 +0100 |
David Soria Parra |
avoid .split() in for loops and use tuples instead
|