Raphaël Gomès <rgomes@octobus.net> [Mon, 04 Nov 2024 13:43:36 +0100] rev 52309
rust-compression: move the `Send` bound to the `Compressor` trait
All compressors should be `Send`, might as well make any future use easier.
Raphaël Gomès <rgomes@octobus.net> [Mon, 04 Nov 2024 12:10:22 +0100] rev 52308
rust-inner-revlog: cache the compressor
The `compress` function is unlikely to be used in highly contended situations,
and creating a compressor has some overhead, on top of losing out on some
potential advantages of longer-running optimizations from the compressor.
Raphaël Gomès <rgomes@octobus.net> [Mon, 04 Nov 2024 11:26:41 +0100] rev 52307
rust-lib: remove exports for not too common pattern-related types
This only muddies the lib and makes the imports more confusing.
Raphaël Gomès <rgomes@octobus.net> [Mon, 04 Nov 2024 11:21:43 +0100] rev 52306
rust-lib: move `PatternError` to the `filepatterns` module
This is where it belongs
Raphaël Gomès <rgomes@octobus.net> [Mon, 04 Nov 2024 11:18:36 +0100] rev 52305
rust-lib: move `Dirstate*Error` to the `dirstate` module
That's where they belong and should always have been there.
Raphaël Gomès <rgomes@octobus.net> [Mon, 04 Nov 2024 11:13:05 +0100] rev 52304
rust-lib: only export very common types to the top of the crate
This was done very early in the Rust project's lifecycle and I had very little
Rust experience. Let's keep the `DirstateParents` since they'll pop up in
all higher-level code and make the rest more explicit imports to make the
imports less confusing and the lib less cluttered.
Raphaël Gomès <rgomes@octobus.net> [Mon, 04 Nov 2024 11:07:05 +0100] rev 52303
rust-dirstate: remove star exports
This makes the crate's imports confusing and muddies the discovery of the
code.
Raphaël Gomès <rgomes@octobus.net> [Mon, 04 Nov 2024 11:00:58 +0100] rev 52302
rust-dirstate: merge `dirstate_tree` module into `dirstate`
The historical reasonning for `dirstate_tree` existing in the first place is
that a new approach was needed for the tree-like dirstate and it was easier
to start somewhat fresh. Now that the former dirstate is (long) gone, we
can merge those two modules to avoid the confusion that even the module
creators sometimes get.
Raphaël Gomès <rgomes@octobus.net> [Mon, 04 Nov 2024 10:38:17 +0100] rev 52301
rust-revlog: rename `end` to `data_end`
This is more explicit.
Raphaël Gomès <rgomes@octobus.net> [Mon, 04 Nov 2024 10:37:42 +0100] rev 52300
rust-revlog: rename `start` to `data_start`
This is more explicit.