Tue, 14 Oct 2014 01:27:25 -0700 |
Pierre-Yves David |
bundle2: add a comment about addchangegroup source and url
|
Wed, 15 Oct 2014 04:19:37 -0700 |
Pierre-Yves David |
pull: call the `b2x-transactionclose` hook when closing the transaction
|
Wed, 08 Oct 2014 02:45:21 -0700 |
Pierre-Yves David |
revset-only: use __nonzero__ to check if a revset is empty
|
Wed, 15 Oct 2014 12:38:47 -0700 |
Pierre-Yves David |
_spanset: drop __getitem__ implementation
|
Wed, 15 Oct 2014 12:38:32 -0700 |
Pierre-Yves David |
filteredset: drop __getitem__ implementation
|
Wed, 15 Oct 2014 04:28:55 -0700 |
Pierre-Yves David |
generatorset: implement __len__
|
Wed, 15 Oct 2014 04:26:23 -0700 |
Pierre-Yves David |
revset: make __len__ part of the offical API
|
Sat, 04 Oct 2014 16:46:50 +0900 |
Yuya Nishihara |
cmdserver: add service that listens on unix domain socket and forks process
|
Sat, 27 Sep 2014 19:18:20 +0900 |
Yuya Nishihara |
test-commandserver: add connector for unix domain socket server
|
Sat, 27 Sep 2014 23:14:26 +0900 |
Yuya Nishihara |
test-commandserver: allow check() to make connection in different way
|
Sat, 27 Sep 2014 22:39:01 +0900 |
Yuya Nishihara |
test-commandserver: remove unused repopath argument from check()
|
Sat, 27 Sep 2014 15:10:14 +0900 |
Yuya Nishihara |
cmdserver: make server streams switchable
|
Sat, 27 Sep 2014 15:04:46 +0900 |
Yuya Nishihara |
cmdserver: switch service objects by mode
|
Sat, 27 Sep 2014 14:52:09 +0900 |
Yuya Nishihara |
cmdserver: wrap 'pipe' mode server by service object
|
Thu, 16 Oct 2014 14:55:45 -0400 |
Augie Fackler |
histedit: miscellaneous style cleanups
|
Thu, 16 Oct 2014 14:51:15 -0400 |
Augie Fackler |
histedit: update docstring on histeditstate.read()
|
Thu, 16 Oct 2014 14:49:46 -0400 |
Augie Fackler |
histedit: remove now-superfluous repo argument from processreplacement
|
Wed, 15 Oct 2014 08:38:36 -0700 |
David Soria Parra |
histedit: move locks into state
|
Wed, 15 Oct 2014 08:38:16 -0700 |
David Soria Parra |
histedit: read state from histeditstate
|
Wed, 15 Oct 2014 08:18:26 -0700 |
David Soria Parra |
histedit: pass state to action functions
|
Thu, 16 Oct 2014 10:06:49 -0700 |
David Soria Parra |
histedit: pass state to processreplacement
|
Wed, 15 Oct 2014 08:06:15 -0700 |
David Soria Parra |
histedit: pass state to boostrapcontinue
|
Wed, 15 Oct 2014 17:11:54 -0700 |
David Soria Parra |
histedit: let the state expose a context but serialize correctly to nodes
|
Wed, 15 Oct 2014 17:30:57 -0700 |
David Soria Parra |
histedit: add clear method to remove state
|
Tue, 14 Oct 2014 20:35:17 -0700 |
David Soria Parra |
histedit: use state object where necessary
|
Wed, 15 Oct 2014 17:17:12 -0700 |
David Soria Parra |
histedit: add histedit state class
|
Fri, 17 Oct 2014 02:07:05 +0900 |
FUJIWARA Katsunori |
import-checker: check modules for pure Python build correctly
|
Fri, 17 Oct 2014 02:07:05 +0900 |
FUJIWARA Katsunori |
import-checker: treat "from mercurial import XXXX" style correctly
|
Fri, 17 Oct 2014 02:07:04 +0900 |
FUJIWARA Katsunori |
encoding: avoid cyclic dependency around "parsers" in pure Python build
|
Tue, 14 Oct 2014 01:40:04 -0700 |
Pierre-Yves David |
pull: add source information to the transaction
|
Tue, 14 Oct 2014 00:06:46 -0700 |
Pierre-Yves David |
changegroup: store source and url in the `hookargs` dict
|
Tue, 14 Oct 2014 00:43:20 -0700 |
Pierre-Yves David |
prechangegroup: use hook argument from the transaction
|
Tue, 14 Oct 2014 00:09:25 -0700 |
Pierre-Yves David |
addchangegroup: call `prechangegroup` hook after transaction retrieval
|
Tue, 14 Oct 2014 00:03:03 -0700 |
Pierre-Yves David |
addchangegroup: get the `node` argument of `incoming` hook from transaction
|
Tue, 14 Oct 2014 23:53:35 -0700 |
Martin von Zweigbergk |
dicthelpers: delete now that they are no longer used
|
Tue, 14 Oct 2014 23:18:07 -0700 |
Martin von Zweigbergk |
manifest: transpose pair of pairs from diff()
|
Tue, 14 Oct 2014 22:48:44 -0700 |
Martin von Zweigbergk |
manifest: for diff(), only iterate over files, not flags
|
Tue, 14 Oct 2014 17:09:16 -0700 |
Martin von Zweigbergk |
manifest: repurpose flagsdiff() into (node-and-flag)diff()
|
Thu, 16 Oct 2014 17:03:21 +0900 |
Mike Hommey |
util: add a file handle wrapper class that does hash digest validation
|
Thu, 16 Oct 2014 17:02:51 +0900 |
Mike Hommey |
util: add a helper class to compute digests
|
Thu, 16 Oct 2014 16:03:04 +0900 |
Mike Hommey |
bundle2: merge return values when bundle contains multiple changegroups
|
Thu, 16 Oct 2014 15:54:53 +0900 |
Mike Hommey |
changegroup: use a copy of hookargs when invoking the changegroup hook
|
Thu, 16 Oct 2014 13:48:51 +0900 |
Mike Hommey |
tests: pull common http server setup out of individual tests
|
Wed, 24 Sep 2014 16:00:47 +0900 |
Mike Hommey |
util: move md5 back next to sha1 and allow to call it without an argument
|
Thu, 16 Oct 2014 03:22:51 -0700 |
Pierre-Yves David |
test-bundle2-exchange: do not drop HG_NODE from the hook output
|
Tue, 14 Oct 2014 13:34:57 -0700 |
Durham Goode |
obsolete: update test-commit-amend to use obsolete option
|
Tue, 14 Oct 2014 13:34:25 -0700 |
Durham Goode |
obsolete: update tests to use obsolete options
|
Tue, 14 Oct 2014 13:27:00 -0700 |
Durham Goode |
obsolete: prevent options from being used without createmarkers
|
Tue, 14 Oct 2014 13:26:01 -0700 |
Durham Goode |
obsolete: add exchange option
|
Tue, 14 Oct 2014 13:25:13 -0700 |
Durham Goode |
obsolete: add allowunstable option
|
Tue, 14 Oct 2014 13:23:52 -0700 |
Durham Goode |
obsolete: add createmarkers option
|
Tue, 14 Oct 2014 13:20:31 -0700 |
Durham Goode |
obsolete: add readonly flag to obstore constructor
|
Tue, 14 Oct 2014 13:17:35 -0700 |
Durham Goode |
obsolete: add isenabled function for option checking
|
Wed, 15 Oct 2014 12:52:10 -0700 |
Durham Goode |
obsstore: fix defaultformat option passing
|
Wed, 15 Oct 2014 15:35:59 -0400 |
Augie Fackler |
tests: use $PYTHON instead of hardcoding python
|
Wed, 15 Oct 2014 15:13:43 -0400 |
Augie Fackler |
checklink: always close the NamedTemporaryFile
|
Mon, 13 Oct 2014 11:46:04 +0200 |
Angel Ezquerra |
hgignore: ignore the PyCharm workspace folder
|
Wed, 15 Oct 2014 04:08:06 +0200 |
Mads Kiilerich |
revset: better naming of variables containing the value of a single argument
|
Tue, 14 Oct 2014 14:42:25 -0400 |
Augie Fackler |
manifest: add docstring to text() method
|
Fri, 10 Oct 2014 14:09:37 -0400 |
Augie Fackler |
manifest: rename ambiguously-named set to setflag
|
Sun, 12 Oct 2014 08:29:31 -0700 |
Pierre-Yves David |
bookmarks: inform transaction-related hooks that some bookmarks were moved
|
Sun, 12 Oct 2014 08:03:20 -0700 |
Pierre-Yves David |
phases: inform transaction-related hooks that a phase was moved
|
Mon, 13 Oct 2014 14:52:38 -0700 |
Pierre-Yves David |
test-bundle2: also test the argument of the changegroup hook
|
Mon, 13 Oct 2014 14:47:36 -0700 |
Pierre-Yves David |
test-bundle2: test that we got appropriate hook called with appropriate data
|
Sun, 12 Oct 2014 06:40:36 -0700 |
Pierre-Yves David |
pull: use `stepsdone` instead of `todosteps`
|
Sat, 27 Sep 2014 00:29:06 -0700 |
Pierre-Yves David |
pull: make discovery phase extensible
|
Tue, 14 Oct 2014 21:59:39 +0900 |
Yuya Nishihara |
sshpeer: forward stdout of remote "hg init" to appropriate output channel
|
Wed, 03 Sep 2014 16:34:29 -0400 |
Mike Edgar |
revlog: support importing censored file revision tombstones
|
Tue, 14 Oct 2014 16:16:04 -0400 |
Mike Edgar |
verify: report censored nodes if configured policy is abort
|
Tue, 14 Oct 2014 15:46:16 -0400 |
Mike Edgar |
context: handle censored data in an on-disk file context based on config
|
Wed, 08 Oct 2014 15:20:14 -0400 |
Augie Fackler |
manifest: add fastdelta method to manifestdict
|
Wed, 08 Oct 2014 15:21:59 -0400 |
Augie Fackler |
manifest: move _search to module level and rename to _msearch
|
Wed, 08 Oct 2014 14:47:30 -0400 |
Augie Fackler |
manifest: move manifestdict-to-text encoding to manifest class
|
Fri, 03 Oct 2014 13:22:31 -0700 |
Martin von Zweigbergk |
localrepo: access status fields by name rather than index
|
Sat, 11 Oct 2014 22:43:14 -0700 |
Martin von Zweigbergk |
subrepo: use separate instances of empty lists in status
|
Fri, 03 Oct 2014 09:29:48 -0700 |
Martin von Zweigbergk |
summary: make status code more readable
|
Sat, 04 Oct 2014 20:53:05 -0700 |
Martin von Zweigbergk |
strip: make checklocalchanges() return full status tuple
|
Sat, 04 Oct 2014 21:58:01 -0700 |
Martin von Zweigbergk |
fileset: access status fields by name rather than index
|
Sat, 04 Oct 2014 21:19:44 -0700 |
Martin von Zweigbergk |
histedit: access status fields by name rather than index
|
Fri, 03 Oct 2014 22:12:43 -0700 |
Martin von Zweigbergk |
shelve: access status fields by name rather than index
|
Fri, 03 Oct 2014 10:44:07 -0700 |
Martin von Zweigbergk |
record: access status fields by name rather than index
|
Fri, 03 Oct 2014 10:38:43 -0700 |
Martin von Zweigbergk |
purge: access status fields by name rather than index
|
Fri, 03 Oct 2014 22:10:08 -0700 |
Martin von Zweigbergk |
largefiles: access status fields by name rather than index
|
Fri, 03 Oct 2014 10:05:54 -0700 |
Martin von Zweigbergk |
keyword: access status fields by name rather than index
|
Fri, 03 Oct 2014 09:51:39 -0700 |
Martin von Zweigbergk |
hgcia: access status fields by name rather than index
|
Sat, 04 Oct 2014 21:05:41 -0700 |
Martin von Zweigbergk |
context: store status class instead of plain tuple in self._status
|
Fri, 10 Oct 2014 10:14:35 -0700 |
Martin von Zweigbergk |
status: update and move documentation of status types to status class
|
Tue, 14 Oct 2014 00:52:27 -0500 |
Martin von Zweigbergk |
status: update various other methods to return new class
|
Fri, 10 Oct 2014 14:32:36 -0700 |
Martin von Zweigbergk |
status: create class for status lists
|
Fri, 03 Oct 2014 21:21:20 -0700 |
Martin von Zweigbergk |
lfutil: avoid creating unnecessary copy of status tuple
|
Fri, 03 Oct 2014 21:44:10 -0700 |
Martin von Zweigbergk |
dirstate: separate 'lookup' status field from others
|
Mon, 13 Oct 2014 14:18:47 -0700 |
Martin von Zweigbergk |
commit: update file nodeid and flags in the same place
|
Mon, 13 Oct 2014 14:11:47 -0700 |
Martin von Zweigbergk |
commit: use separate variable for p1 manifest and new manifest
|
Mon, 13 Oct 2014 14:34:53 -0700 |
Martin von Zweigbergk |
commit: remove dead initialization of 'lock'
|
Mon, 13 Oct 2014 16:43:37 -0700 |
Martin von Zweigbergk |
commit: reduce scope of 'removed' variable
|
Mon, 13 Oct 2014 18:00:39 -0500 |
Matt Mackall |
rebase: fix some weird mixed-case naming
|
Mon, 13 Oct 2014 17:55:45 -0500 |
Matt Mackall |
rebase: move duplicatecopies next to merge
|
Mon, 13 Oct 2014 17:12:47 -0500 |
Matt Mackall |
histedit: use merge.graft
|
Mon, 13 Oct 2014 17:12:31 -0500 |
Matt Mackall |
graft: use merge.graft
|
Mon, 13 Oct 2014 17:12:12 -0500 |
Matt Mackall |
merge: add merge.graft helper
|
Mon, 13 Oct 2014 14:33:13 -0500 |
Matt Mackall |
duplicatecopies: move from cmdutil to copies
|
Mon, 13 Oct 2014 14:04:11 -0500 |
Matt Mackall |
histedit: fix indent
|
Mon, 13 Oct 2014 13:21:03 -0500 |
Matt Mackall |
graft: move rebase cleanup code next to actual rebase
|
Fri, 10 Oct 2014 13:44:40 -0500 |
Matt Mackall |
shelve: add a bundlerepo method
|
Sat, 11 Oct 2014 14:05:09 -0500 |
Matt Mackall |
dirstate: merge falls through to otherparent
|
Fri, 10 Oct 2014 13:31:06 -0500 |
Matt Mackall |
dirstate: use 'm' state in otherparent to reduce ambiguity
|
Fri, 10 Oct 2014 13:05:50 -0500 |
Matt Mackall |
dirstate: properly clean-up some more merge state on setparents
|
Tue, 07 Oct 2014 11:42:37 -0700 |
Durham Goode |
phases: move root phase assignment to it's own function
|
Tue, 07 Oct 2014 11:37:54 -0700 |
Durham Goode |
phases: add invalidate function
|
Sun, 12 Oct 2014 23:30:04 -0700 |
Durham Goode |
phases: change phase command change detection
|
Fri, 10 Oct 2014 13:09:22 -0700 |
Pierre-Yves David |
spanset: remove `.set()` definition
|
Fri, 10 Oct 2014 13:08:49 -0700 |
Pierre-Yves David |
generatorset: remove `.set()` definition
|
Fri, 10 Oct 2014 13:08:28 -0700 |
Pierre-Yves David |
addset: remove `.set()` definition
|
Fri, 10 Oct 2014 13:08:10 -0700 |
Pierre-Yves David |
filteredset: remove `.set()` definition
|
Fri, 10 Oct 2014 13:07:35 -0700 |
Pierre-Yves David |
baseset: remove `set()` definition
|
Fri, 10 Oct 2014 11:27:57 -0700 |
Pierre-Yves David |
abstractsmartset: remove `set()` method definition
|
Fri, 10 Oct 2014 14:27:05 -0700 |
Pierre-Yves David |
match: check if an object is a baseset using `isascending` instead of `set`
|
Fri, 10 Oct 2014 14:22:23 -0700 |
Pierre-Yves David |
getset: check if an object is a baseset using `isascending` instead of `set`
|
Fri, 10 Oct 2014 13:24:57 -0700 |
Pierre-Yves David |
fullreposet: detect smartset using "isascending" instead of "set"
|
Fri, 10 Oct 2014 13:21:05 -0700 |
Pierre-Yves David |
fullreposet: drop custom sets but not smartsets detection
|