comparison debian/rules @ 2072:c0a685c67c5c

debian: don't delete evolve and topic extensions The debian packaging rules deletes all __init__.py to avoid conflicting with the __init__.py that declares the namespace package. Now that the evolve and topic extensions also live in __init__.py files, we clearly don't want to delete all __init__.py files anymore; only the hgext3rd/__init__.py should be deleted.
author Martin von Zweigbergk <martinvonz@google.com>
date Thu, 09 Mar 2017 12:47:31 -0800
parents 9590332b26c8
children 9fa3585b160f
comparison
equal deleted inserted replaced
2071:8fbf75ca8a08 2072:c0a685c67c5c
16 override_dh_auto_test: hgsrc_defined 16 override_dh_auto_test: hgsrc_defined
17 cd tests && python $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist 17 cd tests && python $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist
18 endif 18 endif
19 19
20 override_dh_python2: 20 override_dh_python2:
21 # avoid conflict with mercurial's own hgext/__init__.py 21 # avoid conflict with mercurial's own hgext3rd/__init__.py
22 find debian -name __init__.py -delete 22 find debian -path '*/hgext3rd/__init__.py' -delete
23 dh_python2 23 dh_python2
24 24
25 override_dh_auto_clean: clean-docs 25 override_dh_auto_clean: clean-docs
26 dh_auto_clean 26 dh_auto_clean
27 rm -f tests/*.err 27 rm -f tests/*.err