comparison debian/rules @ 4911:ddfc0b16c9d7 stable

debian: make it possible to by-pass doc build
author Denis Laxalde <denis@laxalde.org>
date Thu, 17 Oct 2019 20:33:02 +0200
parents 56a8fbdd6090
children cac7e750422f
comparison
equal deleted inserted replaced
4910:7ddb17901934 4911:ddfc0b16c9d7
2 #export DH_VERBOSE=1 2 #export DH_VERBOSE=1
3 3
4 %: 4 %:
5 dh $@ --with python2,sphinxdoc --buildsystem=pybuild 5 dh $@ --with python2,sphinxdoc --buildsystem=pybuild
6 6
7 ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS)))
7 override_dh_auto_build: 8 override_dh_auto_build:
8 dh_auto_build 9 dh_auto_build
9 # Workaround for Sphinx in Debian Buster defaulting to Python 3 10 # Workaround for Sphinx in Debian Buster defaulting to Python 3
10 SPHINXBUILD="python -m sphinx -bhtml" $(MAKE) -C docs 11 SPHINXBUILD="python -m sphinx -bhtml" $(MAKE) -C docs
12 endif
11 13
12 hgsrc_defined: 14 hgsrc_defined:
13 # Use "! -z" instead of "-n", because "-n" without arguments is true 15 # Use "! -z" instead of "-n", because "-n" without arguments is true
14 test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false) 16 test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false)
15 17