Mercurial > evolve
view debian/rules @ 6884:053ce6e0b3b7 stable
tests: add a correct test header to test-tutorial.t
Otherwise the title of the entire HTML doc is "Initial setup".
author | Anton Shestakov <av6@dwimlabs.net> |
---|---|
date | Wed, 02 Oct 2024 20:13:39 +0400 |
parents | 623517b1d83b |
children |
line wrap: on
line source
#!/usr/bin/make -f #export DH_VERBOSE=1 %: dh $@ --with python3,sphinxdoc --buildsystem=pybuild ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS))) override_dh_auto_build: dh_auto_build $(MAKE) -C docs endif hgsrc_defined: # Use "! -z" instead of "-n", because "-n" without arguments is true test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false) ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: hgsrc_defined cd tests && python3 $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist endif override_dh_python3: # avoid conflict with mercurial's own hgext3rd/__init__.py find debian -path '*/hgext3rd/__init__.py' -delete dh_python3 override_dh_auto_clean: dh_auto_clean rm -f tests/*.err $(MAKE) -C docs clean