Mercurial > evolve
view debian/rules @ 2409:2b563a725cdc
obsdiscovery: add more debug output
we add a summary debug output to help gathering data.
author | Pierre-Yves David <pierre-yves.david@octobus.net> |
---|---|
date | Thu, 18 May 2017 17:03:11 +0200 |
parents | c0a685c67c5c |
children | 9fa3585b160f |
line wrap: on
line source
#!/usr/bin/make -f #export DH_VERBOSE=1 %: dh $@ --with python2 --buildsystem=python_distutils override_dh_auto_build: dh_auto_build $(MAKE) -C docs hgsrc_defined: # Use "! -z" instead of "-n", because "-n" without arguments is true test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false) ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: hgsrc_defined cd tests && python $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist endif override_dh_python2: # avoid conflict with mercurial's own hgext3rd/__init__.py find debian -path '*/hgext3rd/__init__.py' -delete dh_python2 override_dh_auto_clean: clean-docs dh_auto_clean rm -f tests/*.err clean-docs: rm -rf html rm -f docs/static/logo-evolve.ico rm -f docs/tutorials/tutorial.rst