view debian/rules @ 6794:68f7ba35ea83 stable

topic: bring back oldbranchmap context manager for hg 4.9 This is only needed in Mercurial 4.9 because branchcache class there tries to use super() in its __init__() and it results in an infinite recursion because we also implement __init__() with super() in _topiccache and then replace the original branchmap.branchcache class with our own. At least there are now compatibility comments to help remove this hack ASAP.
author Anton Shestakov <av6@dwimlabs.net>
date Thu, 27 Jun 2024 16:59:29 +0400
parents 623517b1d83b
children
line wrap: on
line source

#!/usr/bin/make -f
#export DH_VERBOSE=1

%:
	dh $@ --with python3,sphinxdoc --buildsystem=pybuild

ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS)))
override_dh_auto_build:
	dh_auto_build
	$(MAKE) -C docs
endif

hgsrc_defined:
	# Use "! -z" instead of "-n", because "-n" without arguments is true
	test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false)

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test: hgsrc_defined
	cd tests && python3 $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist
endif

override_dh_python3:
	# avoid conflict with mercurial's own hgext3rd/__init__.py
	find debian -path '*/hgext3rd/__init__.py' -delete
	dh_python3

override_dh_auto_clean:
	dh_auto_clean
	rm -f tests/*.err
	$(MAKE) -C docs clean