Mercurial > evolve
view debian/rules @ 6351:ab052cdaa813 mercurial-5.4
test-compat: merge mercurial-5.5 into mercurial-5.4
author | Anton Shestakov <av6@dwimlabs.net> |
---|---|
date | Thu, 08 Dec 2022 20:44:26 +0400 |
parents | 0562705ae984 |
children | 623517b1d83b |
line wrap: on
line source
#!/usr/bin/make -f #export DH_VERBOSE=1 %: dh $@ --with python3,sphinxdoc --buildsystem=pybuild ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS))) override_dh_auto_build: dh_auto_build $(MAKE) -C docs endif hgsrc_defined: # Use "! -z" instead of "-n", because "-n" without arguments is true test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false) ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS))) override_dh_auto_test: hgsrc_defined cd tests && python $(HGSRC)/tests/run-tests.py --with-hg=$(HGSRC)/hg --blacklist=$(CURDIR)/debian/test-blacklist endif override_dh_python3: # avoid conflict with mercurial's own hgext3rd/__init__.py find debian -path '*/hgext3rd/__init__.py' -delete dh_python3 override_dh_auto_clean: dh_auto_clean rm -f tests/*.err $(MAKE) -C docs clean