view debian/rules @ 1184:bc601c010185 stable

evolve: remove the use of `rebase.concludenode` Half of this function is now done in `merge.graft` and the over part is easy to redo manually. So we remove the usage of this function to remove the dependency of evolve on the rebase extension.
author Pierre-Yves David <pierre-yves.david@fb.com>
date Sat, 13 Dec 2014 18:09:23 -0800
parents f0978cb993a0
children 9590332b26c8
line wrap: on
line source

#!/usr/bin/make -f
#export DH_VERBOSE=1

%:
	dh $@ --with python2 --buildsystem=python_distutils

override_dh_auto_build:
	dh_auto_build
	$(MAKE) -C docs

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg` --blacklist=$(CURDIR)/debian/test-blacklist
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2

override_dh_auto_clean: clean-docs
	dh_auto_clean
	rm -f tests/*.err

clean-docs:
	rm -rf html
	rm -f docs/static/logo-evolve.ico
	rm -f docs/tutorials/tutorial.rst