diff mercurial/localrepo.py @ 14220:21b8ce4d3331

rename path_auditor to pathauditor The Mercurial 1.9 release is moving a lot of stuff around anyway and we are already moving path_auditor from util.py to scmutil.py for that release. So this seems like a good opportunity to do such a rename. It also strengthens the current project policy to avoid underbars in names.
author Adrian Buehlmann <adrian@cadifra.com>
date Fri, 06 May 2011 09:54:06 +0200
parents 0013d3eeb826
children df2399663392
line wrap: on
line diff
--- a/mercurial/localrepo.py	Fri May 06 12:09:20 2011 +0200
+++ b/mercurial/localrepo.py	Fri May 06 09:54:06 2011 +0200
@@ -30,7 +30,7 @@
         self.root = os.path.realpath(util.expandpath(path))
         self.path = os.path.join(self.root, ".hg")
         self.origroot = path
-        self.auditor = scmutil.path_auditor(self.root, self._checknested)
+        self.auditor = scmutil.pathauditor(self.root, self._checknested)
         self.opener = scmutil.opener(self.path)
         self.wopener = scmutil.opener(self.root)
         self.baseui = baseui