diff debian/rules @ 4909:56a8fbdd6090 stable

debian: use pybuild and dh_sphinxdoc Use pybuild because it's kind of standard nowadays. Use sphinxdoc debhelper to have a Depends: libjs-sphinxdoc and common files (JS/CSS) symlinked.
author Denis Laxalde <denis.laxalde@logilab.fr>
date Fri, 11 Oct 2019 17:05:37 +0200
parents 6292fe564b20
children ddfc0b16c9d7
line wrap: on
line diff
--- a/debian/rules	Tue Oct 15 11:41:22 2019 +0200
+++ b/debian/rules	Fri Oct 11 17:05:37 2019 +0200
@@ -2,7 +2,7 @@
 #export DH_VERBOSE=1
 
 %:
-	dh $@ --with python2 --buildsystem=python_distutils
+	dh $@ --with python2,sphinxdoc --buildsystem=pybuild
 
 override_dh_auto_build:
 	dh_auto_build