view debian/rules @ 725:235a942eba3f stable

debian: honor nocheck in DEB_BUILD_OPTIONS
author Julien Cristau <julien.cristau@logilab.fr>
date Fri, 31 May 2013 15:10:34 +0200
parents 47246c32e0fb
children d3bfd03cb26e
line wrap: on
line source

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

ifeq (,$(filter nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`
endif

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2