view debian/rules @ 535:47246c32e0fb stable

pkg-debian: remove conflicting __init__.py files
author Pierre-Yves David <pierre-yves.david@logilab.fr>
date Thu, 30 Aug 2012 14:01:29 +0200
parents b18b00036355
children 235a942eba3f
line wrap: on
line source

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2