diff debian/rules @ 531:b18b00036355 stable 1.0.0

pkg/debian: Debian packaging This change add the necessary files to create a debian package for the evolve extension. I do not care about the rest.
author Pierre-Yves David <pierre-yves.david@logilab.fr>
date Wed, 29 Aug 2012 11:36:10 +0200
parents
children 47246c32e0fb
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/debian/rules	Wed Aug 29 11:36:10 2012 +0200
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+
+%:
+	dh $@ --with python2 --buildsystem=python_distutils
+
+build:
+	dh build --with python2 --buildsystem=python_distutils
+	$(MAKE) -C docs
+
+.PHONY: build
+
+override_dh_auto_test:
+	cd tests &&  python run-tests.py --with-hg=`which hg`