view debian/rules @ 590:02cadd3dc9f4

evolve: adapt to 2.4 code
author Pierre-Yves David <pierre-yves.david@logilab.fr>
date Tue, 23 Oct 2012 17:12:53 +0200
parents 47246c32e0fb
children 235a942eba3f
line wrap: on
line source

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2