view debian/rules @ 652:5a929510de9d

merge with filtering change (DO NOT USE WITHOUT FILTERING)
author Pierre-Yves David <pierre-yves.david@logilab.fr>
date Fri, 04 Jan 2013 12:43:22 +0100
parents 47246c32e0fb
children 235a942eba3f
line wrap: on
line source

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2