view debian/rules @ 702:b5a85a8909d3 stable

touch: properly handle touching multiple changeset
author Pierre-Yves David <pierre-yves.david@ens-lyon.org>
date Fri, 08 Feb 2013 22:44:43 +0000
parents 47246c32e0fb
children 235a942eba3f
line wrap: on
line source

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2