view debian/rules @ 619:f50f8da7a077 compat-hg2.3

add a -e option to fold
author Denis Laxalde <denis.laxalde@logilab.fr>
date Mon, 26 Nov 2012 11:59:40 +0100
parents 47246c32e0fb
children 235a942eba3f
line wrap: on
line source

#!/usr/bin/make -f

%:
	dh $@ --with python2 --buildsystem=python_distutils

build:
	dh build --with python2 --buildsystem=python_distutils
	$(MAKE) -C docs

.PHONY: build

override_dh_auto_test:
	cd tests &&  python run-tests.py --with-hg=`which hg`

override_dh_python2:
	# avoid conflict with mercurial's own hgext/__init__.py
	find debian -name __init__.py -delete
	dh_python2